The onboarding notification should have "do not show this again" checkbox

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: arai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Steps to reproduce:
  1. open Nightly 56.0a1 (2017-06-29) (64-bit) on macOS
  2. open a new tab
  3. click "x" button of the onboarding notification
  4. open a new tab

Actual result:
  onboarding notification appears with sliding animation every time I open new tab,
  that is very distracting, especially the animation is.

Expected result:
  the onboarding notification should have a checkbox with "do not show this again"

  Apparently the "Hide the tour" checkbox in the top-left fox icon disables the notification, but it's hard to discover it, when one wants to disable the onboarding notification that is shown at the bottom of the page.

Updated

a year ago
See Also: → bug 1377336

Updated

a year ago
Duplicate of this bug: 1377336
Verdi, how do you think?
Flags: needinfo?(mverdi)
Whiteboard: [photon-onboarding][triage]

Updated

a year ago
Depends on: 1357641
Per PM Peter's comment, keep the current design behavior. change this to WONTFIX, remove whiteboard tag.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Whiteboard: [photon-onboarding][triage]
(Reporter)

Comment 4

a year ago
which comment?
Flags: needinfo?(frlee)
the discussion was happened on the weekly onboarding meeting last week
per PM's comment as below:

pdol [10:39 AM]
@here: I spoke with @verdi and @jdavidson yesterday about the dismissal of notifications.  The decision is to stick with the currently designed experience, whereby clicking the x dismisses that particular notification, but the rest will still show.  Adding a tooltip on the x will be the simplest way to mitigate the issue.  We'll monitor for feedback in pre-release and in the diary study.  If we need to adjust we could consider an uplift later, but we're not too concerned.
Flags: needinfo?(frlee)

Updated

a year ago
Flags: needinfo?(mverdi)
You need to log in before you can comment on or make changes to this bug.