Status

()

P3
critical
VERIFIED INVALID
20 years ago
19 years ago

People

(Reporter: dr, Assigned: rogerl)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
i compiled the nightly source distribution from 13 sept 99 on the following
system:

SunOS mothra 5.7 Generic sun4u sparc SUNW,Ultra-Enterprise

and got the following results:

mothra /tmp/dr/mozilla/dist/bin -> ./mozilla-apprunner.sh
MOZILLA_FIVE_HOME=/tmp/dr/mozilla/dist/bin
  LD_LIBRARY_PATH=/tmp/dr/mozilla/dist/bin
      MOZ_PROGRAM=./apprunner
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nsNativeComponentLoader: autoregistering /tmp/dr/mozilla/dist/bin/components
nsNativeComponentLoader: autoregistering succeeded
nsUnixToolkitService: Using 'gtk' for the Toolkit.
NS_SetupRegistry() MOZ_TOOLKIT=gtk, WIDGET_DLL=libwidget_gtk.so,
GFX_DLL=libgfx_gtk.so
GFX: dpi=100 t2p=0.0694444 p2t=14.4 depth=24
Using '/tmp/dr/mozilla/dist/bin' as the resource: base
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileName : mozProfile
ProfileDir  : /home/dr/.mozilla/mozProfile
Profile Manager : Profile Wizard and Manager activites : End
Bus Error

ouch. here is the stack trace:

Program received signal SIGBUS, Bus error.
0xff1812c8 in XPT_MakeCursor (state=0xda1d8, pool=XPT_HEADER, len=0,
    cursor=0xad0159d1) at xpt_xdr.c:262
262         cursor->state = state;
(gdb) where
#0  0xff1812c8 in XPT_MakeCursor (state=0xda1d8, pool=XPT_HEADER, len=0,
    cursor=0xad0159d1) at xpt_xdr.c:262
#1  0xff17bf94 in getHeader (
    filename=0x147398 "/tmp/dr/mozilla/dist/bin/components/xpcom_base.xpt",
    al=0x1471e8) at nsInterfaceInfoManager.cpp:158
#2  0xff17c0e8 in nsInterfaceInfoManager::indexify_file (this=0x153ac0,
    filename=0x147398 "/tmp/dr/mozilla/dist/bin/components/xpcom_base.xpt")
    at nsInterfaceInfoManager.cpp:181
#3  0xff17c838 in nsInterfaceInfoManager::initInterfaceTables (this=0x153ac0)
    at nsInterfaceInfoManager.cpp:373
#4  0xff17bd0c in nsInterfaceInfoManager::nsInterfaceInfoManager (
    this=0x153ac0) at nsInterfaceInfoManager.cpp:106
#5  0xff17ba14 in nsInterfaceInfoManager::GetInterfaceInfoManager ()
    at nsInterfaceInfoManager.cpp:67
#6  0xff17cfb4 in XPTI_GetInterfaceInfoManager ()
    at nsInterfaceInfoManager.cpp:527
#7  0xff16ff70 in nsProxyEventClass::GetNewOrUsedClass (aIID=@0xfd7a1ab8)
    at nsProxyEventClass.cpp:74
#8  0xff17139c in nsProxyEventObject::GetNewOrUsedProxy (destQueue=0x47008,
    proxyType=5, aObj=0xa6c90, aIID=@0xfd7a1ab8) at nsProxyEventObject.cpp:48
#9  0xff1735d4 in nsProxyObjectManager::GetProxyObject (this=0xd81f0,
    destQueue=0x47008, aIID=@0xfd7a1ab8, aObj=0xa6c90, proxyType=5,
    aProxyObject=0xd3e44) at nsProxyObjectManager.cpp:185
#10 0xfd75bf30 in nsNetModRegEntry::nsNetModRegEntry (this=0xd3e38,
    aTopic=0xfcbb7658 "component://netscape/network/moduleMgr/http/request",
    aNotify=0xa6c90, result=0xffbef004) at nsNetModRegEntry.cpp:124
#11 0xfd7593f4 in nsNetModuleMgr::RegisterModule (this=0x15cfc8,
    aTopic=0xfcbb7658 "component://netscape/network/moduleMgr/http/request",
    aNotify=0xa6c90) at nsNetModuleMgr.cpp:56
#12 0xfcba86f8 in nsCookieService::Init (this=0xb29d0)
    at nsCookieService.cpp:137
#13 0xfcba82e8 in nsCookieService::nsCookieService (this=0xb29d0)
    at nsCookieService.cpp:97
#14 0xfcba83c4 in nsCookieService::GetCookieService (aCookieService=0xffbef288)
    at nsCookieService.cpp:106
#15 0xfcba8284 in NS_NewCookieService (aCookieService=0xffbef288)
    at nsCookieService.cpp:91
#16 0xfcba8f8c in nsCookieServiceFactory::CreateInstance (this=0xbd1d8,
    aOuter=0x0, aIID=@0x2cd0c, aResult=0xffbef3f4) at nsCookieService.cpp:223
#17 0xff14f440 in nsComponentManagerImpl::CreateInstance (this=0x30780,
    aClass=@0x1b54c, aDelegate=0x0, aIID=@0x2cd0c, aResult=0xffbef3f4)
    at nsComponentManager.cpp:1218
#18 0xff1624d8 in nsComponentManager::CreateInstance (aClass=@0x1b54c,
    aDelegate=0x0, aIID=@0x2cd0c, aResult=0xffbef3f4) at nsRepository.cpp:77
#19 0xff163a34 in nsServiceManagerImpl::GetService (this=0x2d898,
    aClass=@0x1b54c, aIID=@0x2cd0c, result=0xffbef5b0, shutdownListener=0x0)
#20 0xff164478 in nsServiceManager::GetService (aClass=@0x1b54c,
    aIID=@0x2cd0c, result=0xffbef5b0, shutdownListener=0x0)
    at nsServiceManager.cpp:443
#21 0x18d8c in ?? ()
#22 0x15b94 in ?? ()
#23 0x15ff8 in ?? ()

i have had similar problems with crashes on startup in solaris 7 before...

Updated

20 years ago
Severity: major → critical

Updated

20 years ago
Assignee: don → pavlov

Updated

19 years ago
Assignee: pavlov → rogerl

Comment 1

19 years ago
mcafee said to reassign it to you and that you guys could work together on this.

Updated

19 years ago

Comment 2

19 years ago
dunk is running Solaris 2.7 which is "Solaris 7.0".

Comment 3

19 years ago
This bug is nearly two months old. Is it reproducable?

The stack trace makes it look like it was not in xpconnect or xptcall.
nsInterfaceInfoManager and libxpt is pretty much mccabe's world.

Also, this is coming in from the proxy code. Might this not be on the main
thread? Is there a chance that this is a threadsafety issue as the main thread
is also init'ing the typelib system? just a thought.

Updated

19 years ago
Component: Browser-General → XPCOM

Comment 4

19 years ago
dr: what compiler did you use here?
(Reporter)

Comment 5

19 years ago
I actually don't remember, since this was quite a while ago, but I would guess
it was gcc 2.7.2.3. I have since converted to gcc 2.95.1, and haven't had this
problem since...

I would say you should close this bug out, but it's your call.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

19 years ago
I'm closing this bug out, since it's old, ambiguous, and not very helpful.
Solaris problems are usually in tor@cs.brown.edu's domain anyway.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Marking Verified as Invalid.
You need to log in before you can comment on or make changes to this bug.