stylo: Check full-screen-api.unprefix.enabled pref for :fullscreen pseudo-class

RESOLVED DUPLICATE of bug 1374902

Status

()

RESOLVED DUPLICATE of bug 1374902
a year ago
a year ago

People

(Reporter: xidorn, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
We need to check full-screen-api.unprefix.enabled pref when parsing :fullscreen pseudo-class, otherwise we are unintentionally shipping :fullscreen selector.

Also note that, we want :fullscreen to be available in user agent sheet unconditionally, so we would need to do something like bug 1375374.

There is currently no test checking this. We should add test to file_fullscreen-unprefixed-disabled-inner.html to ensure we don't regress it.
Priority: -- → P3
Priority: P3 → --
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374902
You need to log in before you can comment on or make changes to this bug.