If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in mozalloc_abort | abort | webrender::render_backend::{{impl}}::run

RESOLVED FIXED in Firefox 56

Status

()

Core
Graphics: WebRender
--
critical
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: marcia, Assigned: sotaro)

Tracking

({crash})

56 Branch
mozilla56
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
This bug was filed from the Socorro interface and is 
report bp-05caeca6-0b64-4311-a0e6-cabaf0170629.
=============================================================

Using today's nightly I am getting this crash when resizing my browser window.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0 ID:20170629100331 CSet: 9af23c413a1f8d337b19b4f8450e241e91b71136

STR:

1. With Webrender enabled, after crashing I come to the session restore window.
2. Resize the browser window.
3. Crash 100%
Whiteboard: [gfx-noted]
(Assignee)

Updated

3 months ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 1

3 months ago
The crash seemed to be caused by incorrect update_image() usage. And SendUpdateImage() is only used in nsChildView::AddWindowOverlayWebRenderCommands(). Then it seems to cause the problem.
(Assignee)

Comment 2

3 months ago
nsChildView::AddWindowOverlayWebRenderCommands() was added by bug 1368846.
Blocks: 1368846
(Assignee)

Comment 3

3 months ago
Created attachment 8882976 [details] [diff] [review]
patch - Replace ImageKey when image size is changed
(Assignee)

Updated

3 months ago
Attachment #8882976 - Flags: review?(bugmail)
Attachment #8882976 - Flags: review?(bugmail) → review+
(Assignee)

Comment 4

3 months ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=06e5c6cfb6d2450a8e1e7008823029bc894dfd49

Comment 5

3 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aba2f559df0f
Replace ImageKey when image size is changed r=kats

Comment 6

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/aba2f559df0f
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.