can't open specific website

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
a year ago
6 months ago

People

(Reporter: yucife, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needsdiagnosis])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8882493 [details]
firefox.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

http://tawtheef.sec.gov.qa


Actual results:

Firefox won't respond

Comment 1

a year ago
repro due to unresponsive script:

54.0 te, 54.0.1 bn-in
55.0b5 en-us
56.0a1 bn-in [ build: 20170629150231 ]

does the "unresponsive script" issues belong here or report to website maintainers ?
It seems there's a while loop in the website which executes forever on Firefox, and that won't apply to Chrome:

      if (Sys.Browser.agent == Sys.Browser.Firefox) {
        a._inputFile.size = 20;
        var c = a._inputFile.offsetWidth;
        a._inputFile.style.width = '';
        while (a._inputFile.offsetWidth < c) a._inputFile.size++
      }
Component: Untriaged → General
Product: Firefox → Web Compatibility
Version: 54 Branch → unspecified
Component: General → Desktop
Product: Web Compatibility Tools → Tech Evangelism
Whiteboard: [needsdiagnosis]
Seems like they fixed this, or redesigned.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.