"Save Link As..." escapes characters in filename (e.g. spaces -> %20)

VERIFIED DUPLICATE of bug 76799

Status

Core Graveyard
File Handling
--
minor
VERIFIED DUPLICATE of bug 76799
16 years ago
2 years ago

People

(Reporter: James Chaldecott, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

I've only checked this with images(so far), but I imagine it is generic.

Selecting "Save Link As..." or shift-clicking a link to an image file (any
file?) with spaces (any non-standard?) character replaces the spaces with %20 in
the filename that appears in the "Save As..." dialog.

Very similar to Bug 130079 


Reproducible: Always
Steps to Reproduce:
1. Go to URL (http://www.swythan.co.uk/imagetest.html)
2. Shift click the thumbnail


Actual Results:  The filename in the dialog is "Chopper%20Exit.jpg"

Expected Results:  Should have been "Chopper Exit.jpg"

Comment 1

16 years ago
Reporter: Pls get the latest build from
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
to see if the problem still exist.

The Mozilla build you are using is a month ago, which seems a bit too old...

Comment 2

16 years ago
Reads like dupe of bug 133746

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 133746 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Re-duping to the root bug of this dupe tree for proper freq count
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 76799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.