IntersectionObserver: Property isIntersecting of entries is undefined

RESOLVED DUPLICATE of bug 1319137

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1319137
11 months ago
11 months ago

People

(Reporter: jochen, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

Expanded the example uploaded for bug report 1377581 to report the isIntersecting property on the only entry provided to the callback.


Actual results:

Property came back as undefined. Same code gave me true/false (i.e. the expected boolean) in current Chrome.


Expected results:

Chrome devs do not meet MDN specification with regards to crossing the threshold outwards (false) or inwards (true). Any ratio > 0 is true for them. Would be nice if FireFox could get this right.

Updated

11 months ago
Blocks: 1243846
Component: Untriaged → Layout
Product: Firefox → Core

Updated

11 months ago
Flags: needinfo?(tschneider)
I tested the described test case in latest FF Nightly and was not able to reproduce. Jochen, can you provide the version of Firefox in which you tested this in?
Flags: needinfo?(tschneider) → needinfo?(jochen)
Ok, I could see in other bug reports that you are testing this in FF 54. And, yes, I was able to reproduce the reported issue. Support for the isIntersecting property landed via Bug 1319137 and will be available in FF 55.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(jochen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1319137
You need to log in before you can comment on or make changes to this bug.