Intermittent TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-schemes.html | expected OK

RESOLVED DUPLICATE of bug 1387285

Status

()

RESOLVED DUPLICATE of bug 1387285
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog][stockwell fixed:product])

9 failures in 718 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 8
* mozilla-inbound: 1

Platform breakdown:
* linux64: 7
* linux64-stylo: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-06-26&endday=2017-07-02&tree=all
See Also: → bug 1326505, bug 1314834
Whiteboard: [necko-backlog]
20 failures in 656 pushes (0.03 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 5
* try: 2
* mozilla-central: 2

Platform breakdown:
* linux64-stylo: 10
* linux64: 6
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-07-03&endday=2017-07-09&tree=all
Test timeout because content process is crashed.
>Hit MOZ_CRASH(LoadInfo not thread-safe) at /home/worker/workspace/build/src/xpcom/base/nsISupportsImpl.cpp:43

Need to get the full crash stack to understand which usage of LoadInfo is causing this error.
25 failures in 720 pushes (0.035 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 12
* mozilla-inbound: 11
* mozilla-central: 2

Platform breakdown:
* linux64-stylo: 14
* linux64: 6
* linux32: 3
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-07-10&endday=2017-07-16&tree=all
this is failing at the >3 times/day rate- closer to 5x/day.  

here is a recent log:
https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=114979689&lineNumber=3457

:mcmanus, would it be possible to see if there is something simple going on here?
Flags: needinfo?(mcmanus)
both loadinfo and corslistenerproxy are apparently being used by the wrong thread.. but there's no stack.

This is actually not a necko test.. maybe ben has some insight into debug?
Flags: needinfo?(mcmanus) → needinfo?(bkelly)
:mcmanus, thanks for redirecting this properly- do you know what component this test should live in?  I want to make sure we have test cases mapped to the right components so we don't file bugs in the wrong places.
Flags: needinfo?(mcmanus)
fetch api is, right now anyhow, a dom concept.
Flags: needinfo?(mcmanus)
So, the test is exercising code-paths where we fail due to unexpected schemes during redirect.  So nsCORSListenerProxy fails to QI to an http channel since its not http.  This then causes the CORS redirect handler to fail and cancel the channel.  It seems when we cancel the channel here we can end up releasing the channel via a runnable on the wrong thread.

I have no idea what that runnable is without a stack, though.

Joel, can we fix stack reporting for MOZ_CRASH() in content processes in WPT?  I think that would help with other future bugs as well.

Note, we can't just avoid adding the CORS listener here because the request starts as http and tries to redirect to a different scheme.
Flags: needinfo?(bkelly) → needinfo?(jmaher)
:ahal, are you familiar with MOZ_CRASH and wpt much?
Flags: needinfo?(jmaher) → needinfo?(ahalberstadt)
Not really, I could probably do some digging and figure something out, but jgraham could investigate a lot quicker.
Flags: needinfo?(ahalberstadt) → needinfo?(james)
27 failures in 822 pushes (0.033 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 12
* autoland: 10
* try: 4
* mozilla-central: 1

Platform breakdown:
* linux64-stylo: 14
* linux64: 10
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-07-17&endday=2017-07-23&tree=all
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a908f48c3ae934681449ad3d165e2d6311e959fe&selectedJob=117036365 has a fixup in the harness to improve the handling of content crashes.
Flags: needinfo?(james)
Depends on: 1384063
39 failures in 1008 pushes (0.039 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 14
* mozilla-inbound: 10
* pine: 7
* try: 6
* oak: 1
* mozilla-central: 1

Platform breakdown:
* linux64-stylo: 18
* linux64: 10
* linux32: 5
* windows7-32: 4
* osx-10-10: 1
* linux64-qr: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-07-24&endday=2017-07-30&tree=all
Bug 1387285 has a stack for this now.  The channel is getting released on the SocketTransportThread for some reason which I think lets me play hot potato back to team necko...
Depends on: 1387285
22 failures in 888 pushes (0.025 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 6
* mozilla-central: 3
* try: 1
* mozilla-beta: 1

Platform breakdown:
* linux64-stylo: 9
* linux32: 6
* linux64: 5
* windows7-32: 1
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-07-31&endday=2017-08-06&tree=all
4 failures in 901 pushes (0.004 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 2
* mozilla-central: 1
* mozilla-beta: 1

Platform breakdown:
* linux64-stylo: 3
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1377627&startday=2017-08-07&endday=2017-08-13&tree=all
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1387285
Whiteboard: [necko-backlog] → [necko-backlog][stockwell fixed:product]
You need to log in before you can comment on or make changes to this bug.