[RFE] UI for setting an Alarm (for Schedule, ToDo, Call, Anniversary, etc.)

RESOLVED WORKSFORME

Status

Calendar
General
--
enhancement
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Peter Lairo, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
UI for setting an Alarm (for Schedule, ToDo, Call, Anniversary, etc.)

Screenshot shows suggested UI.

should be able to:
- set/cancel an alarm
- set before or after time or specific date (or accept default)
- set alarm sound (or accept default)
- type a message to be displayed
- enter path to program to be executed
(Reporter)

Updated

16 years ago
Blocks: 122644
(Reporter)

Comment 1

16 years ago
Created attachment 79440 [details]
Suggested UI and features for setting alarms.

Comment 2

16 years ago
Why would you want to set an appointment alarm to go off after the 
appointment?  Or at a time unrelated to the appointment?

It would simplify things a lot for the user if you removed the before/after/on 
radio buttons, and the date/time pickers, and just left the two controls to the 
right of the before/after radios, preferably with the text ' before' after the 
duration combo.
(Reporter)

Comment 3

16 years ago
> Why would you want to set an appointment alarm to go off after the 
appointment?  

Because it may not be an "appointment"; it's may be an *event*. For instance, if
you miss a report submittal deadline by more than 14 days, you pay 10% penalty
fee. Therefore, someone might want to be notified 9 days *after* the event to be
able to take mergency actions to avoid the penalty.

> Or at a time unrelated to the appointment?

Sometimes it is useful to be notified of an event on a *specific* date. I have
used this in the past (occasionally).

Of course, the *default* should be "x days before the event", since it is used
the most (but not exclusively).
Keywords: mozilla1.1

Updated

16 years ago
Keywords: mozilla1.1

Comment 4

16 years ago
I won't be doing this.
Anyone who wants to do this can just assign the bug to themselves.
Assignee: mikep → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Severity: normal → enhancement
Summary: UI for setting an Alarm (for Schedule, ToDo, Call, Anniversary, etc.) → [RFE] UI for setting an Alarm (for Schedule, ToDo, Call, Anniversary, etc.)
(Reporter)

Updated

15 years ago
Keywords: helpwanted, ui

Comment 5

12 years ago
This bug is fixed now IMO.

Comment 6

12 years ago
(In reply to comment #5)
> This bug is fixed now IMO.
> 

We are still missing:
(In reply to comment #0)
> should be able to:
> - set specific date
> - type a message to be displayed
> - enter path to program to be executed

It may be open to debate which of these should ultimately be supported, but for
now this is still valid.

Updated

12 years ago
QA Contact: colint → sunbird

Comment 7

12 years ago
(In reply to comment #6)
Not to be obnoxious, but I'd definately support the implementation of the "path to program to be executed" feature.
Most of the options have been implemented as comment 5 correctly states. The remaining options are either planned to be implemented (specific date/time), have certain security implications (program to be executed) or are better served in a extension (message to be displayed).

Therefore remsolving as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Component: Sunbird Only → General
Keywords: helpwanted
QA Contact: sunbird → general
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.