"Remove from history" (one item) removes all downloads from the same URL

RESOLVED DUPLICATE of bug 825887

Status

()

RESOLVED DUPLICATE of bug 825887
2 years ago
2 years ago

People

(Reporter: tustamido, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170629005143

Steps to reproduce:

- Download the same file twice or more (use different names or save to different folders, doesn't matter).
- Right click one of the downloads, "Remove from history".


Actual results:

- All downloads of the same file are removed from the list.


Expected results:

- Only the selected download should be removed.


Tested in 54.0.1 and 56.0a1 20170630030203 in safemode.

I can get the expected result by pressing delete. "Remove from history" should have the same effect as delete key (remove just the selected item).
(Reporter)

Comment 1

2 years ago
It seems that in All Downloads (Places Organizer) you need to select the oldest download (among the repeated ones) to reproduce this bug.

But in downloadsPanel the order doesn't matter, you can reproduce it by selecting any of the repeated ones.

That's the real behavior difference. It's not a matter of pressing delete or clicking "Remove from history" in contextmenu, these two actions are the same.
Component: Untriaged → Downloads Panel

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Downloads Panel → Bookmarks & History
Resolution: --- → DUPLICATE
Duplicate of bug: 825887
You need to log in before you can comment on or make changes to this bug.