If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

stylo: site issue: enforced mobile version on tweakers.net

VERIFIED DUPLICATE of bug 1372041

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 1372041
3 months ago
3 months ago

People

(Reporter: Timvde, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8882862 [details]
Comparison between stylo disabled (top) and stylo enabled (bottom)

With `layout.css.servo.enabled` set to `true`, desktop Nightly renders https://tweakers.net/ with mobile CSS applied. Screenshot attached. Top one is the normal desktop site (stylo disabled), bottom one is what very much looks like the mobile website (stylo enabled).
(Reporter)

Updated

3 months ago
Blocks: 1243581
Thanks for reporting this bug. Let it block the meta bug that we're currently tracking during dog-fooding.
Blocks: 1375906
No longer blocks: 1243581
Summary: Firefox renders mobile version of tweakers.net with Stylo enabled → stylo: Firefox renders mobile version of tweakers.net with Stylo enabled
Thank you!
Removing
<link rel="stylesheet" href="https://tweakimg.net/x/min/grade_md.css?1498734470" type="text/css" media="(max-width: 1000px),(max-device-width: 1000px) and (orientation: portrait),(max-device-width: 767px) and (orientation: landscape)">
<link rel="stylesheet" href="https://tweakimg.net/x/min/grade_sm.css?1498564686" type="text/css" media="(max-width: 767px),(max-device-width: 767px) and (orientation: portrait),(max-device-width: 499px) and (orientation: landscape)">
<link rel="stylesheet" href="https://tweakimg.net/x/min/grade_xs.css?1498564686" type="text/css" media="(max-width: 499px),(max-device-width: 499px) and (orientation: portrait)">
seems to fix it.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372041
Nightly 56 x64 20170703100343 @ Debian Testing (Linux 4.9.0-3-amd64, Radeon RX480)
about:support > Stylo: true (enabled by user)

Verified fixed: https://tweakers.net/
Status: RESOLVED → VERIFIED
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: stylo: Firefox renders mobile version of tweakers.net with Stylo enabled → stylo: site issue: enforced mobile version on tweakers.net
You need to log in before you can comment on or make changes to this bug.