Duplicate characters when changing the text case value on input event

RESOLVED FIXED in Firefox 57

Status

()

Firefox for Android
Keyboards and IME
RESOLVED FIXED
11 months ago
9 months ago

People

(Reporter: Vincent Ricard, Assigned: jchen)

Tracking

54 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 months ago
Created attachment 8882869 [details]
Page to reproduce the bug

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36

Steps to reproduce:

* Open the attachment
* Type 'a'
* Type 'b'




Actual results:

You get 'AAB'


Expected results:

You should get 'AB'
(Reporter)

Comment 1

11 months ago
The bug seems occur when the value is transformed (with toUpperCase or a String.replace).
JChen would you take a look at this?
Flags: needinfo?(nchen)
(Assignee)

Updated

11 months ago
Assignee: nobody → nchen
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(nchen)
(Assignee)

Comment 3

9 months ago
Created attachment 8897068 [details] [diff] [review]
Reset keyboard when composition is lost (v1)

Normally, we keep the Java composition when composition is committed on
the Gecko side. However, if we somehow lose the composition on the Java
side (e.g. due to script changing the text), we should reset the
keyboard so it's aware of the change.
Attachment #8897068 - Flags: review?(esawin)

Updated

9 months ago
Attachment #8897068 - Flags: review?(esawin) → review+

Comment 4

9 months ago
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91aeee278ee2
Reset keyboard when composition is lost; r=esawin

Comment 5

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/91aeee278ee2
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(Assignee)

Updated

9 months ago
Flags: needinfo?(nchen)

Comment 6

9 months ago
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/59d0f9b5458b
Follow-up to add null check for editable; r=me
(Assignee)

Updated

9 months ago
Flags: needinfo?(nchen)
You need to log in before you can comment on or make changes to this bug.