Closed Bug 1377765 Opened 2 years ago Closed 2 years ago

Firefox for Android freezes when focusing datetime-local input field

Categories

(Firefox for Android :: General, defect)

56 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 56
Tracking Status
firefox56 --- fixed

People

(Reporter: isaacschemm, Assigned: isaacschemm)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Android 5.0; Mobile; rv:56.0) Gecko/56.0 Firefox/56.0
Build ID: 20170702100336

Steps to reproduce:

ASUS Z00XS (ZenFone Zoom), Android 5.0

* Visited http://htmlref.labs.oreilly.com/beta/element-input-datetime-local.html
* Touched the datetime-local input field on the bottom of the page to bring focus to it (mouse click also works)


Actual results:

No date/time picker is displayed; Firefox freezes and the OS reports that it is not responding


Expected results:

Either a date/time picker should appear, or (if not supported yet) it should be treated the same as a text input..
Works for me on a Nexus 5x running Android 7 and a Galaxy S6. Might be a Firefox for Android x86 issue.
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> Works for me on a Nexus 5x running Android 7 and a Galaxy S6. Might be a
> Firefox for Android x86 issue.

Huh, never realized it used an x86 processor. That could certainly help narrow down the issue!
Devices:
 - Nexus 5 (Android 6.0.1);
 - Note 4 (Android 5.0.1);
 - Xiaomi Mi Pad 2 (Android 5.1) - x86 architecture.

Hello,

 Tried to reproduce this on several devices in for 56.0a1 and 54.0.1, the issue was not reproducible for me on any of the devices, after tapping on the datetime-locale input the date and time picker was displayed. Seeing as the issue was not reproducible on the Xiaomi, I do not think this is limited to x86 devices only.
OS: Unspecified → Android
Hardware: Unspecified → All
Perhaps it could be ASUS-specific, maybe related to ZenUI?

I can check out and build the code myself if that helps.
I did some investigation this morning. For datetime fields, Firefox actually keeps running, but the dialog is invisible and there's o way to quit, so the user can't do anything else without force closing the applicationn

For date fields (that don't include time), the dialog is shown but no days in the month are shown.

It looks like the same root cause as (or very similar to) bug 1245692. However, that targets Android 4.x and lower specifically; I'm on Android 5.0 (not 5.0.1.)
This patch applies the CalendarView manual height workaround to Android 5.0.x, but not to Android 5.1.x and above.
Attachment #8884553 - Flags: feedback?(andrzej)
Assignee: nobody → isaacschemm
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 8884553 [details] [diff] [review]
1377765-calendar-fix-android5.0.patch

ahunt is not working on Firefox any more. Moving the review. Max are you able to review this?
Attachment #8884553 - Flags: feedback?(andrzej) → review?(max)
Comment on attachment 8884553 [details] [diff] [review]
1377765-calendar-fix-android5.0.patch

Review of attachment 8884553 [details] [diff] [review]:
-----------------------------------------------------------------

I can reproduce the ANR on my htc M7, and also verify the patch fixed the bug. Thanks, Isaac! :)
Attachment #8884553 - Flags: review?(max) → review+
(In reply to Max Liu [:maliu] from comment #8)
> Comment on attachment 8884553 [details] [diff] [review]
> 1377765-calendar-fix-android5.0.patch
> 
> Review of attachment 8884553 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I can reproduce the ANR on my htc M7, and also verify the patch fixed the
> bug. Thanks, Isaac! :)
Thanks for the review! Anything I should do to help get this checked in?
(In reply to Isaac Schemm from comment #9)
> Thanks for the review! Anything I should do to help get this checked in?

Change the status on the bug to assigned instead of new and add checkin-needed as a keyword.
Status: NEW → ASSIGNED
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/26e59e24bc57
Apply calendar height workaround from bug 1245692 to Android 5.0.x. r=maliu
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/26e59e24bc57
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
You need to log in before you can comment on or make changes to this bug.