Closed Bug 1377814 Opened 5 years ago Closed 5 years ago

Smooth scrolling with keyboard/scroll-bar is very unstable

Categories

(Core :: Panning and Zooming, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- verified

People

(Reporter: euthanasia_waltz, Assigned: rhunt)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(1 file)

STR:
1. Start nightly with new profile
2. Hit PageDown key, PageUp key, click scroll-bar, repeat them

AR:
Smooth scrolling doesn't work.

ER:
Smooth scrolling works always.

mozregression:
11:59.35 INFO: Last good revision: 4ba1c894e6064a98ae41a3ec8a624c205c7f0990
11:59.35 INFO: First bad revision: 89be529dbce8bd2dc2351ffe3e4904bc07475aaa
11:59.35 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4ba1c894e6064a98ae41a3ec8a624c205c7f0990&tochange=89be529dbce8bd2dc2351ffe3e4904bc07475aaa

OS:
Windows10, Linux(manjaro, linuxmint)

This occurs on some sites, and it doesn't occur on others.
For example...
occurs @
 https://www.mozilla.org/en-US/firefox/nightly/firstrun/
 https://www.mozilla.org/en-US/privacy/firefox/
 https://developer.mozilla.org/en-US/
not occurs @
 https://blog.nightly.mozilla.org/
 https://planet.mozilla.org/
 https://www.mozilla.org/en-US/about/
unstable @
 https://www.mozilla.org/en-US/contribute/
 (while repeating pageup/pagedown, it sometimes scrolls smoothly)
 https://support.mozilla.org/en-US/kb/get-started-firefox-overview-main-features
 (after a few pagedown key hitting, smooth scrolling becomes working)

...
Duplicate of this bug: 1378006
Duplicate of this bug: 1378040
Copying over some useful info found in the duplicate bugs:

  - The issue seems to happen with apz.keyboard.enabled set to false
    (the current default)

  - "Unstable" seems to mean that sometimes instant scrolling happens
    instead of smooth scrolling
(In reply to atlanto from comment #0)
> 11:59.35 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=4ba1c894e6064a98ae41a3ec8a624c205c7f0990&tochange=89be
> 529dbce8bd2dc2351ffe3e4904bc07475aaa

The two bugs in this range are bug 1376549 or bug 1376538. EyYeballing those two patches, I don't see how bug 1376549 could be responsible, so I assume it's bug 1376538.
Blocks: 1376538
Ryan, it looks like bug 1376538 caused a regression affecting keyboard scrolling in the default configuration (apz.keyboard.enabled=false) that several people have noticed. Could you have a look?
Flags: needinfo?(rhunt)
Keywords: correctness
Priority: -- → P1
Whiteboard: [gfx-noted]
Yes, I'll take a look at this.
Assignee: nobody → rhunt
Flags: needinfo?(rhunt)
I can confirm this is happening.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The problem seems to be the part that schedules empty transactions in bug 1376538, as Botond pointed out. I've been looking into it today, but I don't know if I'll have a solution before the next nightly.

So I think it makes sense to do a partial back out of that change.
Comment on attachment 8883719 [details]
Bug 1377814 - Don't schedule an empty transaction on an APZ focus sequence number update.

https://reviewboard.mozilla.org/r/154624/#review159722
Attachment #8883719 - Flags: review?(botond) → review+
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a2a56dbc6de
Don't schedule an empty transaction on an APZ focus sequence number update. r=botond
https://hg.mozilla.org/mozilla-central/rev/2a2a56dbc6de
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
I'm confirming, that issue is fixed, starting from Mozilla Firefox Nightly 56.0a1 (2017-07-06). Thanks.
Status: RESOLVED → VERIFIED
Keywords: correctnessregression
Version: Trunk → 56 Branch
You need to log in before you can comment on or make changes to this bug.