Lots of nightly tasks failed with ConnectionError: ('Connection aborted.', BadStatusLine("''",))

RESOLVED DUPLICATE of bug 1377754

Status

Release Engineering
Balrog: Backend
RESOLVED DUPLICATE of bug 1377754
4 months ago
3 months ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell infra])

(Reporter)

Description

4 months ago
Lots of failed nightly builds on june 30 and july 2nd like

https://treeherder.mozilla.org/logviewer.html#?job_id=111350963&repo=mozilla-central&lineNumber=1647


Starting new HTTPS connection (1): aus4-admin.mozilla.org
/builds/scriptworker/py27venv/lib/python2.7/site-packages/requests/packages/urllib3/util/ssl_.py:132: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
2017-07-02 03:06:55,257 - DEBUG - retry: Caught exception: 
Traceback (most recent call last):
  File "/builds/scriptworker/tools/lib/python/vendor/redo-1.4.1/redo/__init__.py", line 152, in retry
    return action(*args, **kwargs)
  File "/builds/scriptworker/tools/lib/python/balrog/submitter/cli.py", line 309, in update_dated
    current_data, data_version = api.get_data()
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/balrogclient/api.py", line 193, in get_data
    _, data_version = top_level.get_data()
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/balrogclient/api.py", line 146, in get_data
    resp = self.request()
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/balrogclient/api.py", line 111, in request
    return self.do_request(url, data, method)
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/balrogclient/api.py", line 127, in do_request
    verify=self.verify, auth=self.auth, headers=headers)
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/requests/sessions.py", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/requests/sessions.py", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/builds/scriptworker/py27venv/lib/python2.7/site-packages/requests/adapters.py", line 473, in send
    raise ConnectionError(err, request=request)
ConnectionError: ('Connection aborted.', BadStatusLine("''",))
(Reporter)

Comment 1

4 months ago
Note, this might be a intermittent infra thing - just filing in case it also affects today nightls
Dupe of bug 1377754 ?
(Reporter)

Comment 3

4 months ago
indeed - marking as such , thanks!
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1377754
Whiteboard: [stockwell infra]
You need to log in before you can comment on or make changes to this bug.