Closed Bug 1377848 Opened 3 years ago Closed 3 years ago

nsCSSFrameConstructor::ContentRemoved reconstructs frames synchronously.

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1389743

People

(Reporter: emilio, Unassigned)

References

Details

I think the reconstructs should ideally be async, and wait for the next layout flush.

This should allow Stylo to remove the useless traversals from bug 1374235 without having to relax the assertions.

As noted by Boris in bug 1374235, this is somewhat tricky, but worth getting a bug on file for it, since I'm poking at it a bit this morning.
Priority: -- → P3
I have patches in bug 1389743.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389743
You need to log in before you can comment on or make changes to this bug.