85.67% build times (linux64) regression on push 84a1f64cc8d7bcf668922bd1ebc4d0aff4c43566 (Fri Jun 30 2017)

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: igoldan, Unassigned)

Tracking

({regression})

unspecified
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=84a1f64cc8d7bcf668922bd1ebc4d0aff4c43566

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 86%  build times summary linux64 opt artifact taskcluster-c4.4xlarge     133.25 -> 247.40


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7618

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Blocks: 1377195, 1373320
Component: Untriaged → Disability Access APIs
Product: Firefox → Core
:aklotz This regression is followed by an unrelated improvement. Could you look over this issue, confirm the regression and estimate a fix time?
Flags: needinfo?(aklotz)
Is the regression specific to linux64? Because that patch is Windows-only.
Flags: needinfo?(aklotz)
Yes, this is linux64 specific. No regressions at all show up on Windows.
:aklotz Did you manage to look over this issue, to improve the build time?
Flags: needinfo?(aklotz)
There's nothing that I can do. The code from that patch is not touched on the linux64 build. This must be caused by something else.
Flags: needinfo?(aklotz)
The regression went away, so I will mark this as resolved.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.