intellicast.com - Single letter links do not open appropriate city list

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: chadvanpelt, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
The single-letter alphabetical links on this page should display a list of
cities that begin with the letter selected, but this does not happen in Mozilla
or Netscape 6. It works fine in Netscape 4.08 and IE 5 or 6 therefor leading me
to believe that this is not an error on Intellicast's website.
var isNS = (document.layers) ? 1 : 0;
var isIE = (document.all) ? 1 : 0;

Since mozilla does not support either of those proprietary objects, both
booleans are false in Mozilla.

Then:

function newLocList(newURL) {
	if (newURL != "") {
             if (isIE) document.all.citylist.src = newURL;
             if (isNS) frameElement.src = newURL;
        }
        return false;
}

Ouch.  So if you're not NS4 or IE or supporting their proprietary crap the site
won't work.

Over to evangelism.
Assignee: Matti → doron
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → zach
Version: other → unspecified

Comment 2

16 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Summary: Single letter links do not open appropriate city list → intellicast.com - Single letter links do not open appropriate city list
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.