New tab does not autofocus on the url bar (developer edition)

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: imyxhuang, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Created attachment 8883155 [details]
newtabnoautofocus.gif

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170629075044

Steps to reproduce:

Download and unzip the Linux tarball from https://www.mozilla.org/en-US/firefox/developer/

Run the Firefox executable inside that folder. Open a new tab.


Actual results:

New tabs do not autofocus on the url bar, the search bar, or anything. Animated .gif attached.


Expected results:

Ctrl+t or pressing the new tab button should create a new tab and autofocus the cursor on the url bar/awesome bar.

Updated

8 months ago
Component: Untriaged → Tabbed Browser
(Reporter)

Comment 1

8 months ago
Okay, I can't reproduce this on another computer or even another profile on the same computer. Guess my profile is just corrupted.
Now to copy all of my stuff onto a new profile...
(Reporter)

Comment 2

8 months ago
Hmm, this is odd. I gave up on copying to a new profile and tried safe mode instead. Could not reproduce. Autofocus works fine.
I then tried removing one of my extensions while not in safe mode. It prompted me to restart Firefox, and I did so. Again, could not reproduce.
But when I closed Firefox and started it again with the terminal, the bug is still there.
So it turns out that when Firefox prompts me for a restart from either installing, removing, disabling, enabling etc an extension, it starts fine without the bug. But a "hard" restart of Firefox through closing and opening it will cause the url bar to still not autofocus.
(Reporter)

Comment 3

8 months ago
Never mind. Looks like it works fine with only moz extensions enabled, even after closing and opening Firefox.
Invalid, I hope.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.