Closed Bug 1378073 Opened 3 years ago Closed 3 years ago

Improve perceived Speed on slow responding page/slow webserver

Categories

(Firefox :: General, enhancement)

56 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: maggus.staab, Unassigned)

References

Details

(Keywords: dupeme)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170703030203

Steps to reproduce:

open url https://wiki.mozilla.org/Quantum/Flow#QF_Dashboard

this page seems to be slow at times (what is not the problem I am reporting here).
the page takes seconds to load, because the server-side seem to collect data or something.

In this situation the end-user only sees a spinner in the browser tab and a empty window.
-> on a bigger screen (e.g. 22'') you see a huge area/empty canvas with gray background and the tabbar at the top with a loading indicator.


Actual results:

the site (or browser?) is perceived as beeing slow. Its not transparent to the user whether its a browser issue or a webserver issue, but it feels slow/unresponsive.


Expected results:

I dont have a concrete UI in mind, but I think at least a "loading progress" indicator within the browser window would be awesome.

the progress could maybe even be explained to the end-user, like 
"we are resolving the servers hostname for you" (in case dns is slow)
"the webserver seems to respond in a slowly fashion. please hang on" (in case connection was opened, but the webserver didnt respond with content yet)
"we download the content of the website for you" (in case the page is huge)

this kind of "progress indication" would only be worth it when a sites performance is "slow", I dont think it should be displayed for a page which takes "just 1-3" seconds or similar.
Severity: normal → enhancement
Keywords: dupeme
(In reply to maggus.staab from comment #0)
 
> the progress could maybe even be explained to the end-user, like 
> "we are resolving the servers hostname for you" (in case dns is slow)
> "the webserver seems to respond in a slowly fashion. please hang on" (in
> case connection was opened, but the webserver didnt respond with content yet)
> "we download the content of the website for you" (in case the page is huge)

Should this actually be text? Many people don't understand the tech language. Maybe better some funny animation that entertains the user? What happens if the rendering starts the split second after this gets displayed? That might be very weird for the user as well. Or will FF artificially extend the wait for the content for a couple of seconds so that there is no content "flash"?
Just my five cents.
(In reply to Albert Scheiner [:alberts] from comment #1)
> Should this actually be text? Many people don't understand the tech
> language. Maybe better some funny animation that entertains the user? What
> happens if the rendering starts the split second after this gets displayed?
> That might be very weird for the user as well. Or will FF artificially
> extend the wait for the content for a couple of seconds so that there is no
> content "flash"?
> Just my five cents.

totally agree. my textual representation example was more about which steps the browser could try to visualize to get my point across.

whether this would happen in text-form, a progress-bar or some nice visual image or a animation ... doesnt matter for me ... a UX designer will find a good form for it ;).
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
See Also: → 1355978
We have no plans to do this (and it would be too easily confused with the existing in-content throbber shown when a child process is rendering webcontent too slowly.)
No longer blocks: photon-ui-refresh
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.