Closed Bug 1378097 Opened 5 years ago Closed 4 years ago

Application window border changes to white in Customize mode on Windows 10

Categories

(Firefox :: Theme, defect, P1)

56 Branch
Unspecified
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: ke5trel, Unassigned)

References

Details

(Whiteboard: [reserve-photon-structure] fixed by bug 1366405)

Attachments

(1 file)

In Customize mode the application window border changes from the system specified accent color to white making it slightly harder to distinguish the window boundary.
Whiteboard: [photon-visual]
Whiteboard: [photon-visual] → [photon-visual] [triage]
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1378095
Whiteboard: [photon-visual] [triage] → [photon-structure] [triage]
Probably related to the margin around the window being removed from customize mode. Chances are some obsolete code was left behind that just needs to be removed.
Flags: needinfo?(gijskruitbosch+bugs)
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure] [triage] → [reserve-photon-structure]
(In reply to Dão Gottwald [::dao] from comment #1)
> Probably related to the margin around the window being removed from
> customize mode. Chances are some obsolete code was left behind that just
> needs to be removed.

I don't think so... I just tried and while I can reproduce the bug, I don't see anything obvious css-wise (though it doesn't help that the bug only reproduces while the window is focused, and the inspector obviously unfocuses the window). Removing the customizing and customize-entered attributes doesn't actually change anything. I don't see customize mode adding/removing other attributes when photon is enabled, so I don't understand what other style change we should need here.

Removing -moz-appearance: -moz-win-glass from the window does fix the side and bottom border (the top border disappears), but we apply that outside of customize mode as well and don't seem to need to remove it there to get the right window colours. Did you have something specific in mind?

Note also that on 55 beta, customize mode has the same white border (when the window is focused) - you just notice it less because of the extra backgrounded padding/margins around the edge.

Seems to me this is something that has been this way for a very long time, and it's not immediately obvious to me how it ties into customize mode (or its previous margin/padding implementation) at all... :-(
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(dao+bmo)
Even Firefox 38 (well before we changed stuff for win10 in bug 1169911) has the white border.

I think this is just something we've never noticed that has always been buggy (and I'm not 100% sure on why it's buggy, tbh).
I can't figure out what breaks this either.
Flags: needinfo?(dao+bmo)
It breaks due to the lack of -moz-appearance: -moz-win-exclude-glass in #customization-container which is normally applied by #browser.
Priority: P3 → P4
Depends on: 1366405
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [reserve-photon-structure] → [reserve-photon-structure] fixed by bug 1366405
Target Milestone: --- → Firefox 58
Priority: P4 → P1
I have repro this issue on an old Nightly build 56.0a1 (2017-07-04) running W10.

Verified fixed on latest Nightly 58.0a1 (2017-10-09) and 57.0b6 (2017-10-05) running W10 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.