Closed Bug 1378136 Opened 2 years ago Closed 2 years ago

Wrong Change search settings redirection from about:newtab and about:home

Categories

(Firefox :: Preferences, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 + verified
firefox56 --- fixed
firefox57 --- verified

People

(Reporter: petruta.rasa, Assigned: timdream)

References

Details

(Keywords: regression, verifyme, Whiteboard: [photon-preference])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1372528 +++

[Note]:
- This doesn't reproduce on Firefox 54 beta 13 with one-off searches from awesome bar force enabled 

[Affected versions]:
- Firefox 55 beta 6
- Nightly 56.0a1

[Affected platforms]:
- Win 10 64-bit
- Mac OS X 10.12.5
- Ubuntu 14.04 64-bit

[Steps to reproduce]:
1. Open about:newtab and about:home
2. Enter some text in Search field to open dropdown
3. Select "Change Search Settings" button

[Expected result]:
- On Beta: about:preferences#search opens
- On Nightly: about:preferences#general with focus on Search opens (just like when selecting the button from Search toolbar)

[Actual result]:
- On Beta: about:preferences#general opens
- On Nightly: Focus is on General, not on Search

[Regression range]:
- This happened after bug 1335907 landed (about:preferences reorg)
Hi Francis, this is regressed from bug 135907 on FF55. How are we concerned this on 55 as preferences reorg doesn't ride 55?
Could you take this into photon-preferences triage and suggest the next step for 55? Thanks!
Flags: needinfo?(frlee)
[Tracking Requested - why for this release]: Regression on Fx55, button behavior does not respect pref-off flag.

(In reply to Hsin-Yi Tsai (55 Regression Engineering support) [:hsinyi] from comment #1)
> Hi Francis, this is regressed from bug 135907 on FF55. How are we concerned
> this on 55 as preferences reorg doesn't ride 55?
> Could you take this into photon-preferences triage and suggest the next step
> for 55? Thanks!

It affects Fx55 because the said bug in Fx55 prevents the button to respect the pref-off flag. On Fx55 since we are still use old pref page user should be direct to about:preferences#search instead of about:preferences#general.
Flags: needinfo?(frlee)
Regression in home screen in 55, tracking.
Comment on attachment 8884768 [details]
Bug 1378136 - Redirect user to the general pane for search settings on old preferences page.

https://reviewboard.mozilla.org/r/155648/#review161436
Attachment #8884768 - Flags: review?(jaws) → review+
Assignee: nobody → timdream
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/312f5e3f6a7c
Redirect user to the general pane for search settings on old preferences page. r=jaws
Keywords: checkin-needed
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: -- → P1
QA Contact: hani.yacoub
https://hg.mozilla.org/mozilla-central/rev/312f5e3f6a7c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Uplift request needed.
Flags: needinfo?(timdream)
Flags: needinfo?(timdream)
Keywords: verifyme
Flags: needinfo?(timdream)
Comment on attachment 8884768 [details]
Bug 1378136 - Redirect user to the general pane for search settings on old preferences page.

Approval Request Comment
[Feature/Bug causing the regression]: regression from bug 1335907 
[User impact if declined]: The button will send the user to wrong section of the  Preferences page
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: I've verified it manually, but QA has not
[Needs manual test from QE? If yes, steps to reproduce]: 
Use comment 0, but set browser.preferences.useOldOrganization to true in about:config to simulate the current pref in Beta.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No. It's not a critical feature. Just confusing.
[Why is the change risky/not risky?]: 
[String changes made/needed]: None
Flags: needinfo?(timdream)
Attachment #8884768 - Flags: approval-mozilla-beta?
Comment on attachment 8884768 [details]
Bug 1378136 - Redirect user to the general pane for search settings on old preferences page.

yet more useOldOrganization preferences fallout.  should be in 55.0b11
Attachment #8884768 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed using Firefox 55 beta 12 across platforms.
On Nightly 56.0a1 this fails again due to bug 1365133 (preferences reorg v2) - logged follow-up bug 1384068 for this.
Tested on Windows 10 x64, Mac OS X 10.12 and Ubuntu 16.04. The issue is verified fixed as following, after step 3(same result for both builds and all OS):
 -Latest Nightly :  about:preferences#search with focus on Search opens 
 -Latest Beta    :  about:preferences#search with focus on Search opens 
One additional note:
After the new preferences reorg V2, the Expected for this issue should be changed to:
"On Nightly: about:preferences#search with focus on Search opens"
from 
"On Nightly: about:preferences#general with focus on Search opens (just like when selecting the button from Search toolbar)"
Thank you.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.