When awesomebar "tip" is shown (on input focus) tab navigation no longer works.

RESOLVED DUPLICATE of bug 1385374

Status

()

defect
RESOLVED DUPLICATE of bug 1385374
2 years ago
2 years ago

People

(Reporter: yzen, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
There seems to be a keyboard trap at the time when awesome bar tip is shown and focus is on the input field. The only way to get out is to either perform a search/navigation action or hit F6 to jump to content. This is somewhat inconsistent with the behaviour when the tip is not shown.
Flags: qe-verify?
Priority: -- → P3
Probably an existing bug, and technically not part of Photon, but tagging since it breaks A11Y and can be part of the search box unification needs.
Whiteboard: [reserve-photon-structure] → [reserve-photon-structure][high-priority]
Priority: P3 → P4

Comment 2

2 years ago
Stephen, who knows how this should work instead?
Flags: needinfo?(shorlander)
The Search tip is supposed to be a passive notification. You should still be able to tab as normal.

I think it's part of the autocomplete overlay though, so with no results shown it's probably stealing tab focus.
Flags: needinfo?(shorlander)
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Looks like this is a dupe of bug 1385374, that has been recently fixed.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385374
Flags: qe-verify+
Priority: P4 → --
QA Contact: gwimberly
Whiteboard: [reserve-photon-structure][high-priority]
You need to log in before you can comment on or make changes to this bug.