Closed Bug 1378188 Opened 3 years ago Closed 3 years ago

Spinner styling poor on inactive tabs

Categories

(Firefox :: Theme, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
Iteration:
57.2 - Aug 29

People

(Reporter: mozilla, Assigned: jaws)

References

Details

(Whiteboard: [reserve-photon-animation][fixed by bug 1352119])

Attachments

(3 files)

Attached image SpinnerInactiveTab.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170704030203

Steps to reproduce:

Open two tabs
On the first tab, go to a site that takes a long time to respond so that the spinner stays active long enough for the test
Switch to the second tab


Actual results:

The spinner on the inactive (first) tab becomes almost invisible


Expected results:

The spinner should remain obvious
Attached image SpinnerActiveTab.png
Component: Untriaged → Theme
Whiteboard: [photon-visual][triage]
Whiteboard: [photon-visual][triage] → [photon-animation][triage]
Depends on: 1352119
This will be fixed by bug 1352119 in v57 and after, but before then it may need to be fixed for v56. Moving back to [photon-visual] because I believe it was the visual team who changed the titlebar color to be darker on Windows and thus lowering the contrast on Windows for background tabs loading indicator.
Whiteboard: [photon-animation][triage] → [photon-visual][triage]
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> This will be fixed by bug 1352119 in v57 and after, but before then it may
> need to be fixed for v56. Moving back to [photon-visual] because I believe
> it was the visual team who changed the titlebar color to be darker on
> Windows and thus lowering the contrast on Windows for background tabs
> loading indicator.

The dark title bar isn't and was never supposed to ship in 56.
Whiteboard: [photon-visual][triage] → [photon-animation][triage]
Priority: -- → P3
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
Flags: qe-verify+
QA Contact: jwilliams
Priority: P3 → P4
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Whiteboard: [reserve-photon-animation] → [reserve-photon-animation][fixed by bug 1352119]
Assignee: nobody → jaws
Iteration: --- → 57.2 - Aug 29
Priority: P4 → P1
QA Contact: jwilliams → stefan.georgiev
The spinner is still near-enough invisible.  It's now blue on blue, though.
(In reply to Peter L Jones from comment #4)
> The spinner is still near-enough invisible.  It's now blue on blue, though.

Which theme are you using when you see blue on blue?
Flags: needinfo?(mozilla)
Theme is Default, as it was in the original report.
Firefox is 57.0a1 (2017-08-30) (64-bit).

The blue dot on a pale tab cycling back and forth is visible OK.  However, on a blue tab, it's only the tiny highlight is almost unnoticeable.
Flags: needinfo?(mozilla)
If the active tab (grey) uses the inactive tab colour (blue) for the spinner, the inactive tab (blue) should use the active tab colour (grey) for the spinner.  Of course, the highlight would need taking care of.
(In reply to Peter L Jones from comment #6)

I filed bug 1396062 to investigate and fix your issue. This bug was filed about the old loading indicators which are no longer around. Thanks for commenting here!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0 (20170915100121)

This issue is verified as fixed with the latest Nightly build on 9/15/2017.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.