Unable to load demo_events when running ./manage.py loaddata demo_events

RESOLVED FIXED

Status

Mozilla Reps
reps.mozilla.org
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: jasshultz, Unassigned)

Tracking

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170704100320

Steps to reproduce:

I typed `./manage.py loaddata demo_events` as directed in `http://remo.readthedocs.io/en/latest/installation-virtualenv.html#build-the-environment` step 15.


Actual results:

(venv) ➜  remo git:(master) ✗ ./manage.py loaddata demo_events                                                              
No handlers could be found for logger "product_details"
02:30:1499221804 raven.contrib.django.client.DjangoClient:INFO Raven is not configured (logging is disabled). Please see the documentation for more information. :/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/raven/base.py:188
Traceback (most recent call last):
  File "./manage.py", line 10, in <module>
    execute_from_command_line(sys.argv)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/__init__.py", line 354, in execute_from_command_line
    utility.execute()
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/__init__.py", line 346, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/base.py", line 394, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/raven/contrib/django/management/__init__.py", line 41, in new_execute
    return original_func(self, *args, **kwargs)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/base.py", line 445, in execute
    output = self.handle(*args, **options)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/commands/loaddata.py", line 60, in handle
    self.loaddata(fixture_labels)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/commands/loaddata.py", line 100, in loaddata
    self.load_label(fixture_label)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/management/commands/loaddata.py", line 157, in load_label
    obj.save(using=self.using)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/core/serializers/base.py", line 173, in save
    models.Model.save_base(self.object, using=using, raw=True)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/db/models/base.py", line 771, in save_base
    update_fields=update_fields, raw=raw, using=using)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/dispatch/dispatcher.py", line 189, in send
    response = receiver(signal=self, sender=sender, **named)
  File "/Users/jasonshultz/Projects/remo/remo/reports/models.py", line 348, in create_update_passive_event_report
    activity = Activity.objects.get(name=ACTIVITY_EVENT_CREATE)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/db/models/manager.py", line 127, in manager_method
    return getattr(self.get_queryset(), name)(*args, **kwargs)
  File "/Users/jasonshultz/Projects/remo/venv/lib/python2.7/site-packages/django/db/models/query.py", line 334, in get
    self.model._meta.object_name
remo.reports.models.DoesNotExist: Problem installing fixture '/Users/jasonshultz/Projects/remo/remo/events/fixtures/demo_events.json': Activity matching query does not exist.


Expected results:

It should have loaded the data.
I am trying to fix that from yesterday without any hope.
I didn't find a way to have a better error explanation :-/
(Reporter)

Comment 2

4 months ago
(In reply to Daniele "Mte90" Scasciafratte from comment #1)
> I am trying to fix that from yesterday without any hope.
> I didn't find a way to have a better error explanation :-/

Agreed. I noticed the same behavior when trying to import the data in docker. The data structure seems to be correct when comparing to the other fixtures. I don't know the code base well enough to know for sure what is happening. I'm really dumping in the deep end with this one since I don't know Python . . . yet. :)
Group: mozilla-reps-admins
PR opened here:
https://github.com/mozilla/remo/pull/1363

Comment 4

3 months ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/5f8ecc60269365f2c9cf0de72d3034ecadaea72f
[fix bug 1378264] Add activity data in event fixtures.

https://github.com/mozilla/remo/commit/d21ec57b3fc5302cf0422f42e586294b419b6755
Merge pull request #1363 from akatsoulas/fix-fixture-loading

[fix bug 1378264] Add activity data in event fixtures. Add  data in event fixtures.

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.