Animated gifs on looping occasionally cause crashes

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: orkysoft, Assigned: pavlov)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When I view a website with an animated gif banner on top, and have Mozilla
animate the gif image indefinitely (as often as the image specifies), and leave
it for a while (can be an hour or so), Mozilla sometimes crashes.

I use Mozilla 0.9.9 on Windows 98SE here (Mozilla/5.0 (Windows; U; Win98; en-US;
rv:0.9.9) Gecko/20020311)

I know it is hard to reproduce, especially with 99.9% of you people not letting
Mozilla animate the gifs endlessly (I usually don't either, but once in a while
there actually is a nice animated gif I want to see in more detail), but I've
had it happen more than once. I don't recall the error message exactly, but I
believe (take with grain of salt!) it had to do with IMGLIB.DLL.

It seems a minor inconvenience, but remember this: most ``normal users'' won't
bother to adjust the preferences to disable indefinite looping, whereas advanced
users usually do, so if it's a real bug it WILL be noticed too often.

Otherwise, 0.9.9 is fantastic :-)

Comment 1

17 years ago
Reporter, can you post Talkback ID from your crash ? Run
'mozilla\components\talkback.exe' to see the Talkback IDs when you crashed.
If possible, please try latest nightly build and report if you still crash 'often'.
Build available here:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

17 years ago
It looks like with the newest build (2002041603) it has been solved, as I have
had a page with an animated banner up for a while now, with no crashes.

Comment 3

17 years ago
Reporter (Pieter Uylenbroek) if you no longer see this problem in recent builds
then please could you resolve this bug worksforme. Thanks.
(Reporter)

Comment 4

17 years ago
It's not occurring anymore in recent builds, so it's probably fixed. (Sorry I
didn't change its status earlier, I was unaware I could do that myself.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
Reopening because of wrong resolution. Pieter, could you resolve this bug
worksforme rather than fixed? Fixed is used for when an engineer creates a patch
explicitly for a bug and it is checked in and tested
(http://bugzilla.mozilla.org/bug_status.html). 
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 6

17 years ago
By request of sitsofe@yahoo.com, I changed the status to WORKSFORME, because
there wasn't an explicit patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Thanks Pieter!

Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.