Java Plug-in 1.3 beta causes crash when using navigator.plugins object

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: emk, Assigned: serhunt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
Npjava32.dll in Java Plug-in 1.3 beta has following Plug-in info.

----------------------------------------------------------------------
FileExtents: ||||
FileOpenName: Java Virtual Machine|Java Applet|JavaBeans|Java Applet|JavaBeans
MIMEType: application/x-java-vm|
          application/x-java-applet;version=1.3|
          application/x-java-bean;version=1.3|
          application/x-java-applet;version=1.2.2|
          application/x-java-bean;version=1.2.2|
          application/x-java-applet;version=1.2.1|
          application/x-java-bean;version=1.2.1
----------------------------------------------------------------------

But nsPluginFile::GetPluginInfo assumes that these variant counts are
the same.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
QA Contact: beppe → elig

Comment 1

19 years ago
Could someone please provide a pointer as to how this bug could be verified?

(I see that the Java 1.3 plug-in beta can be downloaded from http://
www.javasoft.com/products/plugin/beta.html.)

Also pinging bug originator to see if he (or she) would like to verify.
(Reporter)

Comment 2

19 years ago
To reproduce:
1. Install Java Plug-in 1.3 beta.
2. Navigate to http://member.nifty.ne.jp/emk/moz/plugins.html

Expected result (an example):
------------------------------------------------------
15 plugins installed.
Shockwave Flash
------------------------------------------------------

Actual result:
It still causes crash.
I'm using [1999093012] build on Windows NT (Service Pack 5).
Everyting works well if I rename npjava32.dll.

Comment 3

19 years ago
Thanks! Andrei, I assume it wasn't checked into yesterday's build, but it's still
crashing using this morning's build 1999100108 on NT 4.0 SP5. Will re-open on
Monday if still present.

(Since it took 15 minutes to register and download the npjava32.dll plug-in, I'm
also attaching it to this bug report.)

Comment 4

19 years ago
Created attachment 1947 [details]
Plug-in referenced in bug report
(Assignee)

Comment 5

19 years ago
Thanks. I'll take a look.
(Assignee)

Comment 6

19 years ago
Strange but I do not see the crash. Should I do anything special to crash it? I
expected it crash on startup.

Comment 7

19 years ago
Sure; just go to the http://member.nifty.ne.jp/emk/moz/plugins.html URL.
(Assignee)

Comment 8

19 years ago
I've just checked in a fix for this.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
verified fixed on [1999100308] WinNT4 (SP5).

Comment 10

19 years ago
Thanks!

Comment 11

19 years ago
[Gave this a quick double-check using 1999 10/3/99 PM M10 build. Confirmed
verified.]
You need to log in before you can comment on or make changes to this bug.