Can't switch input mode of Chinese IME when firefox running with "-no-remote" and default IME is IMM-IME

RESOLVED DUPLICATE of bug 1390097

Status

()

RESOLVED DUPLICATE of bug 1390097
a year ago
a year ago

People

(Reporter: yxu, Unassigned)

Tracking

({inputmethod})

55 Branch
Unspecified
Windows 7
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Mozilla/5.0 (Windows NT 6.1; WOW64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
20170629005143

In 55 version, win7 system. If the user is using third-party input method (such as Sogou, Wanneng Wubi, QQ input). When running firefox with -no-remote way to start, he can not use the Shift key to switch ime to Chinese. Only can input English. And the input method toolbar is not display (that means, you can not use the mouse to switch between Chinese and English).

Microsoft official input method, using shift + ctrl and shift + space to switch between the input method and win10 system work fine.

This problem only appears in the win7 system using the third party input method from the 55 version.

Several input methods Official website:
QQ input: qq.pinyin.cn
Sogou input: pinyin.sogou.com
Wanneng Wubi: www.wnwb.com
Is this the right bugzilla component?
Component: Keyboard: Navigation → Internationalization
Flags: needinfo?(masayuki)
Not sure. And sounds like similar to bug 1378268.

yxu: How about with x86 build (32bit version)?
Flags: needinfo?(masayuki) → needinfo?(yxu)
Component: Internationalization → Widget: Win32
(Reporter)

Comment 3

a year ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
20170713130618  55.0b9
x86 build also has this issue.
Flags: needinfo?(yxu)

Comment 4

a year ago
[Tracking Requested - why for this release]:
A number of Chinese users have reported this problem in Chinese community.
status-firefox55: --- → affected
tracking-firefox55: --- → ?
Duplicate of this bug: 1357355
I cannot reproduce this using QQ PinYin.

(In reply to YF (Yang) from comment #4)
> [Tracking Requested - why for this release]:
> A number of Chinese users have reported this problem in Chinese community.

YF, do you reproduce this since you set status-firefox55 flag?
Flags: needinfo?(yfdyh000)
See Also: → bug 1390097
Ah, OK.  This seems to be 64-bit only.
Flags: needinfo?(yfdyh000)
(I cannot still reproduce this on 32-bit build although reporter says comment #3)

Comment 9

a year ago
(In reply to Makoto Kato [:m_kato] from comment #6)
> I cannot reproduce this using QQ PinYin.
> 
> (In reply to YF (Yang) from comment #4)
> > [Tracking Requested - why for this release]:
> > A number of Chinese users have reported this problem in Chinese community.
> 
> YF, do you reproduce this since you set status-firefox55 flag?

No, I using Windows 10. But it is already reproduced by other peoples.

Chinese threads:
https://www.firefox.net.cn/read-54332-1
http://bbs.kafan.cn/thread-2098798-1-1.html
http://bbs.kafan.cn/thread-2098804-1-1.html
(Reporter)

Comment 10

a year ago
(In reply to Makoto Kato [:m_kato] from comment #6)
> I cannot reproduce this using QQ PinYin.
I can reproduce using QQ Pinyin on win7 both Firefox x86 & x64. It is strange that our performance is different.
Masayuki, as we have difficulties to reproduce it, I guess this isn't super critical?
Flags: needinfo?(masayuki)
I believe that root cause is same as bug 1390097.
Critical, but as Makoto-san said, this must be caused by same reason as bug 1390097 and I'm not sure what is the cause.
Flags: needinfo?(masayuki)
I confirmed that the patch for bug 1390097 also fixes Chinese IMEs too (I tested with Sougou).

# Looks like that some Chinese IMEs don't work partially (e.g., not showing their own popups) with current Nightly.
Depends on: 1390097
See Also: bug 1390097
Keywords: inputmethod
Could you verify if this is fixed on tomorrow's Nightly?
Flags: needinfo?(yxu)
(Reporter)

Comment 16

a year ago
(In reply to Masayuki Nakano [:masayuki] (JST, +0900) from comment #15)
> Could you verify if this is fixed on tomorrow's Nightly?

I test with Nightly 57.0a1 20170827100428 and it works as expected. 

Just one question: When I use QQ Pinyin and set as the default input method, then run firefox with -no-remote mode, I still can't switch ime to Chinese by press Shift, the input method toolbar is not display just like the problem before. But when I press Shift+Ctrl switch to other input method like Sogou, Wanneng Wubi, which have this problem before, they all works fine. After that I continue to press Shift+Ctrl switch back to QQ Pnyin, I can enter the Chinese and the input method toolbar is appeared. both x86 & x64.

I use Sogou, Wanneng Wubi as the default input method then there is no such problem. I can enter the Chinese language directly in the input box without having to switch to another input method and then switch back.

So it seems that the current QQ input is still a problem. Masayuki, can you help to test the question will or will not happened when setting QQ input as default?
Flags: needinfo?(yxu)
I reproduce it but it looks like different bug because QQ input is not an IMM-IME, that is a TIP. If I disable TSF mode with intl.tsf.enable, I can see the toolbar of IME.

So, I guess that should be marked as fixed and QQ input issue should be handled in a new bug.
Summary: Can't switch ime to chinese when firefox running with "-no-remote" → Can't switch input mode of Chinese IME when firefox running with "-no-remote" and default IME is IMM-IME
For now, this should treat only Chinese IMM-IME issues in this bug. I'll file a new bug for QQ input.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390097
No longer depends on: 1390097
Filed bug 1395876 for QQ input case.
status-firefox55: affected → ---
tracking-firefox55: ? → ---
You need to log in before you can comment on or make changes to this bug.