Add to home screen not working on Android O

RESOLVED DUPLICATE of bug 1372926

Status

()

RESOLVED DUPLICATE of bug 1372926
a year ago
6 months ago

People

(Reporter: sebastian, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
We are currently using the INSTALL_SHORTCUT broadcast to add an icon to the home screen. This is not working on Android O anymore.

> The com.android.launcher.action.INSTALL_SHORTCUT broadcast no longer has any 
> effect on your app, because it is now a private, implicit broadcast. Instead, 
> you should create an app shortcut by using the requestPinShortcut() method from 
> the ShortcutManager class.

https://developer.android.com/preview/behavior-changes.html

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372926
You need to log in before you can comment on or make changes to this bug.