Going back/forward in history does not scroll to old location

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Heikki Toivonen (remove -bugzilla when emailing directly), Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla1.1alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

1. Open URL.
2. Scroll down so that you are somewhere in the middle of the document, and
there is still room to scroll up or down, and note the position (for example
"Tax Changes for Businesses" is the first visible line).
3. Go to some other page, and come back

Expected results: you should scroll so that you are were you left, for example
"Tax Changes for Businesses" should be the first visible line

Actual results: scroll position is not accurate, in my case the first thing I
see is "Self-Employment Tax", about an inch above where it should be.

Please see bug 137632 before fixing this for things to look out.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1alpha
I think this was fixed by bug 137632.

*** This bug has been marked as a duplicate of 137632 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
No, I tested after those fixes and this was still happening.

However, using commercial 1.0 branch build from yesterday this bug seems to have
gone away.

Reopening and closing as wfm, will also verify. Sorry for spam.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
wfm 1.0 branch Win2k.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.