Closed Bug 1378591 Opened 4 years ago Closed 2 years ago

Responsive design mode with touch mode on: Select boxes are unselectable

Categories

(DevTools :: Responsive Design Mode, defect, P3)

54 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1318661

People

(Reporter: andreszsogon, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rdm-v2][triage])

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170608105825

Steps to reproduce:

Enable Responsive Design Mode, select a device, activate the TOUCH SIMULATION mode.


Actual results:

All select lists now refuse to drop-down themselves when clicked (or touched).


Expected results:

Select options should've been shown as with regular clicks (no touch simulation mode). This happens on all websites, therefore, it's not a problem with my app.
Component: Untriaged → Developer Tools: Responsive Design Mode
Thanks for filing this!  I would guess that the touch simulator's handling of mouse events prevents the `mozshowdropdown` event from being sent, blocking the drop down list from being shown.

Changing to a more realistic mobile simulation through something like bug 1282089 would be a nice way to resolve this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
See Also: → 1282089
Whiteboard: [rdm-v2][triage]
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318661
You need to log in before you can comment on or make changes to this bug.