xmlextras defaults to wrong encoding in processing responseText

VERIFIED FIXED in mozilla1.2alpha

Status

()

P2
minor
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: gregwhite, Assigned: hjtoi-bugzilla)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Here is some email between myself and Heikki about this:

We default to ISO-8859-1, I can't remember if I tried UTF-8... But since we are
trying to emulate IE, I guess we should try to default to UTF-8. Could
you file a bug with a testcase? I really need a testcase to be sure that we do
what I *think* is happening.

Greg White wrote:

  Hi Heikki,
  I ran into a something that is different in the xmlextras module than the
microsoft version.  I'll leave it up to
  you to call it a bug or not, but if it is intended behaviour, it is probably
worth a line or two of documentation.
  In the absence of other information, Microsoft's widget assumes a default
encoding of utf-8 when handing back
  responseText
(http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xmlsdk/htm/xml_pro_pr_4vqs.asp).
  XML extras doesn't seem to from my tests (it might be assuming ascii, but I am
not sure how to verify that).
  The workaround is to set up the server to always set the charset in the
content-type header and both IE and
  Mozilla worked with that for me.
  - Greg

I will attach a testcase to this once it is submitted.  I know that I am using
an older mozilla, the nightly I have crashes when I try to run this case. :(
(Reporter)

Comment 1

17 years ago
Created attachment 79543 [details]
testcase

This testcase runs under both IE and mozilla.  Demonstrates that mozilla is
assuming a default encoding that is not utf-8.
Priority: -- → P2
Target Milestone: --- → mozilla1.0.1
Target Milestone: mozilla1.0.1 → mozilla1.2alpha
Keywords: nsbeta1+
Comment on attachment 95447 [details] [diff] [review]
fix

r/sr=bzbarsky
Attachment #95447 - Flags: review+
Comment on attachment 95447 [details] [diff] [review]
fix

sr=jst
Attachment #95447 - Flags: superreview+
Checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: petersen → rakeshmishra

Comment 6

16 years ago
verified fixed in trunk build 2003-01-14-08-trunk on win2k , with the test case at
http://green.nscp.aoltw.net/heikki/137866/bug.htm

marking verified 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.