If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Links in moz-extension directory don't work properly

RESOLVED DUPLICATE of bug 1366342

Status

()

Toolkit
WebExtensions: Request Handling
RESOLVED DUPLICATE of bug 1366342
3 months ago
2 months ago

People

(Reporter: 61.1p57, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8883883 [details]
screenshot.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170629005143

Steps to reproduce:

1. View an extension's resources using moz-extension://{id}/
2. Click on any links (to a folder or a file)


Actual results:

Nothing happened


Expected results:

The directory page of the folder should show, or the file should be opened.

Updated

3 months ago
Component: Untriaged → Networking: File
Product: Firefox → Core
Jim, any idea?
Flags: needinfo?(jmathies)
The link to the resource is not "moz-extension://" but "jar:file://", maybe related to bug 1334550?
Flags: needinfo?(jmathies) → needinfo?(haftandilian)
(Reporter)

Updated

3 months ago
Has STR: --- → yes
Version: 55 Branch → 56 Branch
Thanks for reporting this. I'll try to narrow down what introduced this with mozregression.

I tested on Mac and can reproduce this after setting "extensions.webextensions.protocol.remote" to false in about:config (changing this setting requires a browser restart). That setting should disable the work done in bug 1334550. Either way, clicking on a link from the moz-extension://<UUID> listing doesn't result in a request being sent to the ExtensionProtocolHandler.
This doesn't seem like a new problem. I reproduced this with build 55. I'm wondering if it's related to 1256122. Moving this over to the Toolkit -> WebExtensions component.
Component: Networking: File → WebExtensions: Request Handling
Flags: needinfo?(haftandilian)
Product: Core → Toolkit
See Also: → bug 1256122

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1366342
You need to log in before you can comment on or make changes to this bug.