Page with Java causes hang for several minutes

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
5 months ago
5 months ago

People

(Reporter: Craig, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170504112025

Steps to reproduce:

Go to a page with Java on it.
e.g. https://www.java.com/en/download/installed8.jsp?detect=jre


Actual results:

Firefox hangs totally for about 40 seconds, then pops up:
"? may be busy, or it may have stopped responding. You can stop the plugin now, or you can continue to see if the plugin will complete."
If I click "Stop plugin", Firefox hangs again, for 20-40 seconds, then displays the same message again. Repeating that two more times, Firefox eventually continues working.


Expected results:

Java plugin should work. Failing that, clicking "Stop plugin" should work, not have to be clicked 4 times over a 2 minute period before it works.

The quickest way to continue using Firefox is to totally kill the process and re-start!

Firefox 52.1.1ESR
Java Plugin 10.7.2

Updated

5 months ago
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

5 months ago
Since we have removed Java support in Firefox release and are only maintining Java support in ESR for backward compatibility, Mozilla is not going to dedicate engineering time to this problem, and we would only accept a very low-risk patch for the ESR branch.

Given the likelihood of finding a low-risk patch in this code, I'm going to resolve this WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

5 months ago
You seem to be saying that you aren't actually maintaining Java support at all. The exact same setup worked in various older Firefox versions. It's now completely broken, so the backward compatibility isn't there.

For those of us with items such as PTZ cameras which are controlled by Java applets, that basically means either give up FF or find out which older FF version to go back to that actually works.
You need to log in before you can comment on or make changes to this bug.