Proxy: fails to load http over the internet.(AdSubtract installation quirk(

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
--
major
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Garrett Socling, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)
BuildID:    2002031104

When attempting to view a web page using HTTP, Mozilla resolves hosts but then 
just sits, failing to load any information (it just says 'connecting to 
mozilla.org' forever).  FTP connections work fine.

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla
2.Wait...
3.Wait...
4.Repeat forever...

Actual Results:  Mozilla loads into memory, and then it says 'connecting to 
mozilla.org'.  That is all that happens, it never actually downloads anything.

Expected Results:  Download and display mozilla.org.

It doesn't load or display ANY HTTP pages, but on a wild leap of intuition, I 
decided to connect to a FTP server.  I connected to ftp://komodo.mozilla.org 
without a hitch.

Comment 1

16 years ago
Are you using some kind of proxy?
If so: Please see the release notes about proxies and try setting preference for
debug/networking to HTTP 1.0

Comment 2

16 years ago
Reporter mailed:
---------

"Hello,
I tried using it with AdSubtract and without.  Perhaps AdSubtract isn't
compatible with Mozilla, and selecting direct connection to the internet
doesn't really do 'direct connection to the internet', because closing
AdSubtract allows Mozilla to function.  Oddly enough I hadn't thought of
doing this before.  And stranger yet is what happens when I closed
AdSubtract (which forced Mozilla close), and then restarted AdSubtract
and Mozilla.  Everything worked normally.  
Mozilla seemed to correctly find that I was using a proxy during
install, and put the correct information in.  I don't know what
happened, but I am sorry that I hadn't figured out this 'workaround'
without bothering you.
Thanks,
Garrett

Heres a synopsis of what I found:
With AdSubtract running, installing Mozilla doesn't correctly set up
Mozilla to operate with the proxy.
Restarting the computer doesn't help.
What you need to do is close Adsubtract while Mozilla is running.
Adsubtract recognizes Mozilla as a browser and says that they will close
it so that Mozilla will work without Adsubract running.
I then started Adsubtrac, and then Mozilla.  I checked the Mozilla proxy
settings and Adsubtract was still configured as the proxy.  I loaded
msnbc.com and Mozilla correctly downloaded the page and Adsubtract
filtered the ads.
All fixed...if that makes any sense!"

------

Bug 127845 is vaguely related: Adding "AdSubtract" to summary.
Resolving this one as WFM per reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Summary: Mozilla fails to load http over the internet. → Mozilla fails to load http over the internet.(AdSubtract installation quirk(

Comment 3

16 years ago
Okay, this is scary. Some of the behavior I cannot explain, but what I did
understand is this:

If you have AdSubtract running, it is a proxy, so if you do the net-install, you
specify it as the proxy and it installs.

If you are running mozilla, then it takes the proxy prefs and works. (Nobody has
ever said that all-proxy.js worked for them.)

Then again, there are some interations where it did not work well,
install;uninstall;install;(works).

That might actually be related more to the actual bugs in all-proxy.ja, so,
whatever.

VERIFIED: 
we'll conquer this problem for the next person who reports it, and learn more.
Status: RESOLVED → VERIFIED
Summary: Mozilla fails to load http over the internet.(AdSubtract installation quirk( → Proxy: fails to load http over the internet.(AdSubtract installation quirk(
You need to log in before you can comment on or make changes to this bug.