Closed Bug 1378784 Opened 4 years ago Closed 4 years ago

Zoom Indicator Missing When Using Zoom Text Only

Categories

(Firefox :: Address Bar, defect)

54 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- wontfix
firefox55 --- wontfix
firefox56 --- verified

People

(Reporter: basiphobe, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

Use the Zoom Text Only feature, and increase or decrease the zoom level.


Actual results:

The zoom level indicator does not display.


Expected results:

The zoom level indicator should display as it does when Zoom Text Only is disabled. This is a regression, as it used to work in the previous version.
Component: Untriaged → Location Bar
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2ef7b06c606b0334e2a9634ae02b98339ffa7aeb&tochange=e263ffa2eb294aaca7a1935e23de522f71e2ed01


Regressed by: 
e263ffa2eb29	Jared Wein — Bug 1345375 - Use the FullZoomChange event instead of browser-fullZoom observers since FullZoomChange works on MediaDocuments. r=dao
Blocks: 1345375
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jaws)
Has Regression Range: --- → yes
Has STR: --- → yes
Duplicate of this bug: 1381184
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Comment on attachment 8887669 [details]
Bug 1378784 - Listen for TextZoomChange in addition to the FullZoomChange events to update the zoom UI when the zoom changes.

https://reviewboard.mozilla.org/r/158556/#review164038
Attachment #8887669 - Flags: review?(dao+bmo) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6371d6ad918f
Listen for TextZoomChange in addition to the FullZoomChange events to update the zoom UI when the zoom changes. r=dao
https://hg.mozilla.org/mozilla-central/rev/6371d6ad918f
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Jared, did you want to nominate this for Beta or let it ride the 56 train?
Flags: needinfo?(jaws)
Comment on attachment 8887669 [details]
Bug 1378784 - Listen for TextZoomChange in addition to the FullZoomChange events to update the zoom UI when the zoom changes.

Approval Request Comment
[Feature/Bug causing the regression]: regressed by bug 1345375 in Firefox 55
[User impact if declined]: users who use Text Zoom won't see the zoom indicator in the URL bar
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: Change the zoom to Text Only (On Windows, Alt+V -> Zoom -> Zoom Text Only), then zoom in and out of the page (Ctrl+ and Ctrl-, respectively). The zoom indicator should appear in the location bar if the zoom value is anything other than 100%.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no, just adds another listener for the TextZoomChange, we already were listening for FullZoomChange.
[Why is the change risky/not risky?]: see previous answer
[String changes made/needed]: none
Flags: needinfo?(jaws)
Attachment #8887669 - Flags: approval-mozilla-beta?
Minor correction, the regressing bug was initially landed on 55 but was later uplifted to 54 so we have shipped this regression for one release already.
Depends on: 1383662
update, if this gets beta approval, then we should uplift the patches in bug 1383662 also.
Comment on attachment 8887669 [details]
Bug 1378784 - Listen for TextZoomChange in addition to the FullZoomChange events to update the zoom UI when the zoom changes.

I think I'll call this wontfix for 55, since we've shipped this bug already in 54, it doesn't seem critical, and it's late in the cycle with a single build left before RC.
Attachment #8887669 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
no automated test?
Depends on: 1384522
(In reply to Alice0775 White from comment #12)
> no automated test?

I filed bug 1384522 to add an automated test.
I have reproduced this Bug on Nightly 56.0a1 (2017-07-06) on Windows 10, 64 bit!

The bug's fix is now verified on latest  Nightly 56.0a1

Build ID    :	20170729100254
User Agent  : 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170726]
bug has been fixed and resolved
Flags: qe-verify+
I managed to reproduce this bug on an old version of Nightly from 2017-06-15 on Windows 10x64, macOS 10.12 and Ubuntu 16.04 x64.
I retested everything using the same platforms on beta 56.0b11 and latest Nightly 57.0a1 and the bug seems fixed.
Flags: qe-verify+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.