Closed Bug 1378799 Opened 3 years ago Closed 3 years ago

The 'Tracking Protection on/off' slider on about:privatebrowsing page has a brighter color than the Photon spec

Categories

(Firefox :: Theme, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Iteration:
56.3 - Jul 24
Tracking Status
firefox55 --- wontfix
firefox56 --- fixed
firefox57 --- verified

People

(Reporter: brindusat, Assigned: johannh)

References

Details

(Whiteboard: [photon-visual][p3])

Attachments

(2 files)

[Affected versions]: 
Nightly 56.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Open Firefox and go to about:privatebrowsing
2. Compare the page with the photon specs (https://mozilla.invisionapp.com/share/ZKBC94BPQ#/screens/229751570_Private_Browsing).


[Expected result]:
 The page should look like the one from specs.

[Actual result]:
 The 'Tracking Protection on/off' slider on the PB page, set to off position, has a different color(brighter) than the one shown in the image from the invisionapp link (https://mozilla.invisionapp.com/share/ZKBC94BPQ#/screens/229751570_Private_Browsing). Please see the attached screenshot.

Note:
The shape of the ON/OFF slider is a little different - it seems to be shorter and wider.
Whiteboard: [photon-visual]
Whiteboard: [photon-visual] → [photon-visual] [triage]
Priority: -- → P2
Whiteboard: [photon-visual] [triage] → [photon-visual][p3]
Flags: qe-verify+
QA Contact: brindusa.tot
I'm taking this, I need a relaxing task, like adjusting some colors.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Iteration: --- → 56.3 - Jul 24
Priority: P2 → P1
Comment on attachment 8888350 [details]
Bug 1378799 - Adjust the tracking protection toggle colors and dimensions for Photon.

https://reviewboard.mozilla.org/r/159298/#review165478

Thanks!

::: browser/themes/shared/privatebrowsing/aboutPrivateBrowsing.css:126
(Diff revision 1)
>  
>  .toggle + .toggle-btn {
>    box-sizing: border-box;
>    cursor: pointer;
> -  min-width: 42px;
> -  height: 26px;
> +  min-width: 48px;
> +  height: 27px;

Brindusa remarks in comment 0 that the slider is shorter and wider in the spec, but you're actually increasing the height by 1px. Each time I've attempted this review, the invision link has refused to load, but this looks fine to me so I'm not opening an issue.
Attachment #8888350 - Flags: review?(nhnt11) → review+
(In reply to Nihanth Subramanya [:nhnt11] from comment #3)
> Comment on attachment 8888350 [details]
> Bug 1378799 - Adjust the tracking protection toggle colors and dimensions
> for Photon.
> 
> https://reviewboard.mozilla.org/r/159298/#review165478
> 
> Thanks!
> 
> ::: browser/themes/shared/privatebrowsing/aboutPrivateBrowsing.css:126
> (Diff revision 1)
> >  
> >  .toggle + .toggle-btn {
> >    box-sizing: border-box;
> >    cursor: pointer;
> > -  min-width: 42px;
> > -  height: 26px;
> > +  min-width: 48px;
> > +  height: 27px;
> 
> Brindusa remarks in comment 0 that the slider is shorter and wider in the
> spec, but you're actually increasing the height by 1px. Each time I've
> attempted this review, the invision link has refused to load, but this looks
> fine to me so I'm not opening an issue.

True, though I think this was about the general shape and not the exact size. I extracted the image dimensions from the spec and applied them here. :)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46246d4a56a1
Adjust the tracking protection toggle colors and dimensions for Photon. r=nhnt11
https://hg.mozilla.org/mozilla-central/rev/46246d4a56a1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced this Bug on Nightly 56.0a1 (2017-07-06) on Windows 10, 64 bit!

The bug's fix is now verified on latest  Nightly 56.0a1

Build ID    :	20170727100347
User Agent  : 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170726]
I have reproduced this bug with Nightly 56.0a1 (2017-07-06)on Ubuntu 16.04, 64 bit!

The bug's fix is now verified on latest Nightly  57.0a1 (64-bit).

Build ID 	20170802100302
 User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday 20170802]
QA Contact: brindusa.tot → ovidiu.boca
I verified this issue on Mac OS, Windows 10, and Ubuntu 16.04 and I can't reproduce this issue. I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1412789
You need to log in before you can comment on or make changes to this bug.