Closed Bug 1378846 Opened 2 years ago Closed 2 years ago

Stylo: http://www.twcc.com/select-provider#/ doesn't render properly

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Usul, Assigned: xidorn)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

see attached screen shot.

Setting the pref to off and reloading the page fixes the issue.
Investigating...

This seems to be a case from different selector parsing.
Attached file simplified testcase
The website is using a specific selector to do browser-sniff. This case it is the -moz-tree-row pseudo-class, which is part of thing tracked in bug 1348488.
Depends on: 1348488
This is problematic, though, because :-moz-tree-row is a non-standard internal selector. I believe we want to unship it from being accessed from web content at some point.

It is probably worth understanding why this website needs this trick.
Another approach ahead is to unship :-moz-tree pseudos from web content, so that this website becomes broken in Firefox without Gecko (and thus not a regression from stylo). That can be done via bug 1379031.
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #4)
> Another approach ahead is to unship :-moz-tree pseudos from web content, so
> that this website becomes broken in Firefox without Gecko (and thus not a
> regression from stylo). That can be done via bug 1379031.

I meant... without Stylo...
Assignee: nobody → xidorn+moz
AFAICS, this issue would be fixed with my patches in bug 1348488.
Priority: -- → P1
This should now be fixed. Please confirm with the next nightly.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Verified fixed in Nightly 56 x64 20170713100259 @ Debian Testing (Linux 4.11.0-1-amd64, Radeon RX480).
You need to log in before you can comment on or make changes to this bug.