SMALL FONT BUG on Moz 0.9.9 Win32

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: nrg, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
When rendering certain webpages, mozilla 0.9.9 displays the page in a tiny
unreadable font!  Image size is sometimes affected also.  An example of this bug
is available at:

http://services.ic.gc.ca/sitt/portal/LoadHelp.do;jsessionid=0000L451S14DO2YZQAV1W1F5GSI:t60h77pm

or

http://sitt.ic.gc.ca/sitt/portal/GoEnglish.do;jsessionid=0000L451S14DO2YZQAV1W1F5GSI:t60h77pm?LoadMainPortalPage.do

(from http://sitt.ic.gc.ca)


This needs to be fixed ASAP (before 1.0 is released) because i've seen numerous
webpages having this problem!  I believe it's caused by the way Mozilla reads
the font size html tags but this would need to be confirmed.


nrg
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla1.0
There are no <font> tags on the page.  Just bad CSS.

The page loads various stylesheets based on client-sniffing.  For Mozilla on
non-mac it loads the explorer stylesheet.  This sheet has the following rules:

BODY { 
    font-size : 80%;
}

TD { font-size: 80%; }

The site uses nested tables.  To get down to the body content, you have to go
down 3(!) levels.  So you get the following font sizes:

Body:  80% of normal
First level:  80% of body size
Second level: 80% of first level
Third level: 80% of second level

Thus the final font size is (0.8)^4 = 0.4096 of the "normal" font size.

Needless to say, this is tiny.

Both of the pages are from the same site, and the CSS for both is loaded from
the same place.  Reassigning to evangelism so that the page designer will be
contacted and convinced to fix his broken CSS.

Oh, and if IE does _not_ show the text at about 0.4 of the "normal" font size
that's a major CSS-compliance bug in IE.
Assignee: Matti → momoi
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → English: Non-US
Ever confirmed: true
OS: Windows NT → All
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → jeesun
Hardware: PC → All
Target Milestone: mozilla1.0 → ---
Version: other → unspecified

Comment 2

17 years ago
I was about to say the same thing, but I mid-aired. Oh well.

I'll just add one more thing.
If you download a recent build, there's a 'minimum font-size' drop down in
Preferences -> Appearence -> Fonts that let you set a minimum font size to allow
pages to use.

Or instead you can use View->Zoom to zoom in on pages like this.
(Also available as keyboard shortcuts Ctrl+Plus and Ctrl+Minus)
(Reporter)

Comment 3

17 years ago
Just checked with both IE and NS communicator 4.79 and they both display the
font in the correct size.  Since the majority of the internet population has
been assimilated by Micro$oft, most web designers only test their sites in IE.

Because of this, in order for Mozilla to be successful, it is VERY important
that it renders correctly all pages viewable by IE, regardless of standards. 
Standards don't matter when over 80% of the Internet population uses IE!

nrg

Comment 4

17 years ago
If you remove the DOCTYPE, and cause mozilla to fall back to
quirks("compatible") mode, the page will look *readable*. 
*BUT*

By using a strict doctype, the author is basically saying that he's strictly
adhering to the standards and thus the page is rendered according to the standards.

There's no arguing over this.
(Reporter)

Comment 5

17 years ago
Tried the site again using the latest build and minimum size enabled to 10 pt. 
Needless to say, it fixes the font size problem.
However, the min font option is disabled by default when it should be enabled
and set to 10 pt.  Would the person responsible for this feature please change
the default to 10pt?

Thanks

Comment 6

17 years ago
Others might not want to use that option.
In either case, that's outside the scope of this bug.
(Reporter)

Comment 7

17 years ago
I didn't say "Remove the "None" option of Min font size... i said that it should
be set by default to a resonable level (10 pt).  Most newbie users would NEVER
play around in the settings since they are too scared to break something. 
However they WILL use IE instead of Mozilla if their favorite site is displayed
in tiny unreadable fonts!

We screwed up once already with the premature release of Netscape 6!  Let's not
screw up again please!

nrg

Comment 8

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jeesun → english-other
WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.