Yahoo chat page is not rendered properly

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: George Mitchell, Assigned: Darin Fisher)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/00200203
BuildID:    0.9.9

The page http://chat.yahoo.com does not render but instead brings up a file save
dialog. This page works fine in Netscape 4.  At times it does seem to come up,
but when it does it does not render properly at all.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.yahoo.com
2.Click on chat
3.You should end up at http://chat.yahoo.com

Actual Results:  Save dialog came up.

Expected Results:  Chat page should come up with chat dialog

This problem is hardware agnostic.  I discovered the problem on a customer's
computer as a result of customer's complaint and reproduced it on my own. 
Netscape 4.8 does not have the problem, but Netscape 6.2.2 also has the problem
along with Mozilla.

Comment 1

16 years ago
i only get a while page on XP, 2002041603

Comment 2

16 years ago
this is the same on Mac OS X builds (all three). I first noticed then when bug
130740 was marked WFM the work around is to log in to yahoo first then the page
loads.

Comment 3

16 years ago
*** Bug 138393 has been marked as a duplicate of this bug. ***
-> cookies and confirming

Michelle tested it and it works if you login into yahoo and go to chat.yahoo.com.
If you login and delete the login cookie(s) it doesn't work.
It works with IE5.0 and NS4.7x without loggin into yahoo.
Assignee: Matti → morse
Status: UNCONFIRMED → NEW
Component: Browser-General → Cookies
Ever confirmed: true
OS: Linux → All
QA Contact: imajes-qa → tever

Comment 5

16 years ago
It looks like the content model is being truncated -- from the front. IOW, we're
only getting the tail end of the content. cc'ing harishd and darin.
(Assignee)

Comment 6

16 years ago
ok, i took a look and it appears that the server is not sending a standard
header/body delimiter of <crlf>.  instead, ic 3 bytes after the last header..
presumably, <crlflf> or something like that.  at any rate, it confuses our HTTP
header parser immensely ;-)

just take a look at about:cache, locate the entry for chat.yahoo.com, click on
it,  and you'll see the top of the document included as part of the content-type
header ;-)

i have to spend a little more time investigating this to see exactly what
sequence of bytes the server is sending, but we might have to chalk this up as
an evangelism bug.  there's only so much we can do to guess what a server means
when it sends the wrong delimiters.

-> me
Assignee: morse → darin
Component: Cookies → Networking: HTTP
*** Bug 138579 has been marked as a duplicate of this bug. ***
*** Bug 138635 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Same with HTTP/1.0 and 1.1.
Summary: yahoo chat page does not render properly → Yahoo chat page is not rendered properly

Comment 10

16 years ago
Hey, this is working now. 1.0 RC2 branch Build ID: 2002051006 Windows 98. Works
when logged in, works when logged out. Using HTTP/1.1 with pipelining.

Comment 11

16 years ago
On the Mac OS X version of Mozilla build ID 2002051005 with the MRJ Carbon
plugin 1.0fc2 it still doesn't work.   It just freezes the browser which then if
you want to access you still have to force quit.  This is covered in bug 88870,
and apparantly still hasn't been fixed.

Comment 12

16 years ago
The crash/hang bug for http://chat.yahoo.com is bug 143584. 

If you can see the page at http://chat.yahoo.com without being logged into
Yahoo, this bug is fixed.
(Assignee)

Comment 13

16 years ago
mass futuring of untargeted bugs
Target Milestone: --- → Future

Comment 14

16 years ago
This bug also happen when use IE with Microsoft's JVM or Sun's JRE1.4.0 on 
Windows 2000.

It seems that no browser and JVM can run this chatroom.
so maybe it is bug of website.

Comment 15

16 years ago
WFM. Mozilla 1.0RC3 branch Build ID: 2002053106 Windows 98, Sun Java JRE 1.4.
Tested with both HTTP/1.0 and HTTP/1.1 with pipelining.

Have you reinstalled Mozilla from scratch, used a new profile, and reinstalled
Sun Java JRE 1.4? On Windows, what DLL files do you have in your plugins
subdirectory?

Comment 16

16 years ago
This works for me using the latest mozilla nightly builds for mac os x too. 
Maybe this bug should be closed, since it now works.

Comment 17

16 years ago
WFM Mozilla 1.1 alpha Build ID: 2002062713, HTTP/1.1 with pipelining enabled,
Windows 98, Sun Java 1.4.0_01.

No current reports that it is not working. Resolving as worksforme.

The issue with Yahoo chat crashing the browser is bug 143584.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.