Note: There are a few cases of duplicates in user autocompletion which are being worked on.

stylo: Slack channel list's channel names move left and become bold text

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED FIXED
15 days ago
3 days ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 days ago
Created attachment 8884077 [details]
channel-list-screenshot.png

STR:
1. Log into Slack, such as https://mozilla.slack.com/
2. Click on some channel names in the channel list on the left side of the page.

RESULT:
Some channel names will occasionally move to the left and become bold text. The channel names will return to center and normal text if you mouse over them.

Please see the attached screenshot.
I cannot reproduce this, but while using slack on a debug build, it hits
> thread '<unnamed>' panicked at 'Resolving style on element without current styles with lazy computation forbidden.'
as well, which is probably bug 1371450.
I see this too
Ditto. (Microsoft Windows [Version 10.0.15063])
This is biting lots of moco people, since many of them use slack. The user impact isn't severe, but encountering the same issue wastes everyone's time, so we should get this fixed quickly if we can.

Hiro, do you think this is likely related to bug 1371450? Any guesses as to whether it's likely to be fixed by emilio's refactor in bug 1379505?
Flags: needinfo?(hikezoe)
Priority: P2 → P1
Blocks: 1380102
Yes, I believe so.  Clicking channel names on slack site causes the panic in bug 1371450.  And a half-baked patch to fix the panic I have causes another panic, it needs more work...
Depends on: 1371450
Flags: needinfo?(hikezoe)
(In reply to Hiroyuki Ikezoe (:hiro) from comment #5)
> Yes, I believe so.  Clicking channel names on slack site causes the panic in
> bug 1371450.  And a half-baked patch to fix the panic I have causes another
> panic, it needs more work...

The panic was the same as what I commented in bug 1380001 comment 2, so it might be unrelated to the APZ bug.
Created attachment 8885565 [details]
Screenshot from 2017-07-12 10-38-42.png

I saw similar issue on fastmail. When I move mouse over the link they will jump to their original position.

Should I file a new bug?
Hi, Kan-Ru, if you are using linux, would you mind checking the result with the binary in this try? https://treeherder.mozilla.org/#/jobs?repo=try&revision=1c624bcc882f1deee81b325f13ed659ea8d7ff26
If it works fine you don't need to file a new bug for it, it's definitely the same cause of this bug.
(In reply to Hiroyuki Ikezoe (:hiro) from comment #8)
> Hi, Kan-Ru, if you are using linux, would you mind checking the result with
> the binary in this try?
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=1c624bcc882f1deee81b325f13ed659ea8d7ff26
> If it works fine you don't need to file a new bug for it, it's definitely
> the same cause of this bug.

Great. I can't reproduce with this version so it's the same issue.
Closing, as per comment 9, bug 1371450 has been closed.
Status: NEW → RESOLVED
Last Resolved: 3 days ago
Resolution: --- → FIXED
Duplicate of this bug: 1380102
You need to log in before you can comment on or make changes to this bug.