Closed Bug 1379030 Opened 2 years ago Closed 2 years ago

Audio controls in <video> now expands heightwise to obscure captions and poster image

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: mardeg, Assigned: ralin)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(1 file)

STR: Open testcase link in URL field and click on play button.

In order to display captions by default when playing an audio file, a <video> tag must be used. Doing this also means a URL for the poster attribute can be added (and changed throughout playback). These were both visible unobscured by the audio controls on Nightly builds up until the last 1-3 days.

I suspect the regression is caused by either bug 1367868 or bug 1373537.
Keywords: regression
Flags: needinfo?(jaws)
Since it's likely my patch causes the regression, NI myself and I'll look more next week. Thanks Mardeg.
Flags: needinfo?(ralin)
Hi Jared,

Could you help me to review this patch? Thanks.
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Flags: needinfo?(ralin)
Flags: needinfo?(jaws)
Comment on attachment 8884703 [details]
Bug 1379030 - Only set calculated size to controlbar for audio element since audio-only video has already had given size from layout.

https://reviewboard.mozilla.org/r/155572/#review160694
Attachment #8884703 - Flags: review?(jaws) → review+
Thanks :D
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ad99094c54de
Only set calculated size to controlbar for audio element since audio-only video has already had given size from layout. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ad99094c54de
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Since Bug 1373537 is uplifted to 55, we'll need to uplift as well.
Comment on attachment 8884703 [details]
Bug 1379030 - Only set calculated size to controlbar for audio element since audio-only video has already had given size from layout.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1373537
[User impact if declined]: incorrect media controls layout would present while playing audio-only video.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low
[Why is the change risky/not risky?]: one-liner patch, only get rid of the size adjustment for audio-only <video>
[String changes made/needed]: none


Thank you :D
Attachment #8884703 - Flags: approval-mozilla-beta?
(In reply to Ray Lin[:ralin] from comment #8)
> Since Bug 1373537 is uplifted to 55, we'll need to uplift as well.

FWIW it would have been helpful to point that out in bug 1373537 directly (either in your uplift request, or by making that bug depend on this one), or both.
Comment on attachment 8884703 [details]
Bug 1379030 - Only set calculated size to controlbar for audio element since audio-only video has already had given size from layout.

followup fix for bug 1373537, beta55+
Attachment #8884703 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Julien Cristau [:jcristau] from comment #10)
> FWIW it would have been helpful to point that out in bug 1373537 directly
> (either in your uplift request, or by making that bug depend on this one),
> or both.
I'll pay attention to that next time.

Thank you for the help Julien, :Tomcat!
You need to log in before you can comment on or make changes to this bug.