Black screen after accessed http://jsiso.com/

REOPENED
Unassigned

Status

()

Core
Graphics
P3
normal
REOPENED
a year ago
2 months ago

People

(Reporter: vhtnghia, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox59 ?)

Details

(Whiteboard: [gfx-noted])

Attachments

(5 attachments)

(Reporter)

Description

a year ago
Created attachment 8884130 [details]
black-screen-jsiso.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

1. Access http://jsiso.com/
2. Scroll down to the bottom
3. Waiting or open an Example's link.


Actual results:

The black screen cover all tabs, except "New Tab" page. But I can still see the link on the bottom-left of screen.


Expected results:

Nothing happen (meaning no black screen).
Try updating your graphics driver: https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
Component: Untriaged → Graphics
Product: Firefox → Core

Comment 2

a year ago
is this windows specific issue ?

the issue persists when
webgl.disabled false
webgl.disabled true

for above settings, the webpage [ http://jsiso.com/jsiso-samples/public/Samples/sample14/ ] shows only twitter logo only, please find attachment.

repro:
fennec 54.0.1 en-gb
fennec 55.0b5 en-us
fennec 56.0a1 20170706150232 en-gb

device: lyf flame 3 [ ls-4001 ]
os: android 5.1

Comment 3

a year ago
Created attachment 8884162 [details]
twitter logo only jsiso

Comment 4

a year ago
Created attachment 8884166 [details]
memory-report.json.gz

I get a rapid memory increase,followed by  OOM+ crash when i open the URL in foreground.
HEre is a about:memory with the tab opened in background.

Updated

11 months ago
Whiteboard: [gfx-noted]

Comment 6

11 months ago
I'm not able to reproduce this. Can you go to about:support, click "Copy text to clipboard", and paste this here?
Flags: needinfo?(vhtnghia)
Priority: -- → P3
JIT crashes (see comment 5)
Component: Graphics → JavaScript Engine: JIT
Flags: needinfo?(vhtnghia)
Flags: needinfo?(jmuizelaar)
Priority: P3 → --

Comment 8

9 months ago
cant repro anymore with latest nightly.
I tried using mozregression to find the fix, and even with the same build as in comment 5, I cant reproduce.
I guess it must have been something on the page.
Let us know if it comes back, thanks for the original report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME

Comment 10

8 months ago
Created attachment 8920755 [details]
memory-report.json.gz

I can still reproduce this on the latest Nightly. I am able to repro this even from the same build as in comment #8. 
Sorry to have misled you :(
Flags: needinfo?(milan)
Thanks Mayank - just to be clear; you can reproduce as you usually run, but when you try mozregression, you can't reproduce?  What happens if you create a new profile and use it with the nightly, does it reproduce?
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(milan) → needinfo?(vhtnghia)
Resolution: WORKSFORME → ---

Comment 12

8 months ago
I can reproduce on a new profile also with nightly.
It does not happen if the http://jsiso.com/ tab is in the background. Memory increase only happens if the tab is in foreground.
Also, the memory reduces if I got to about:memory and click on minimize memory.

Comment 13

8 months ago
And if I disable HWA, I cant reproduce this.
Given comment 13, turfing back to Graphics.

The crashes in comment 5 are really out-of-memory crashes (in jemalloc, failing to commit memory pages), not JIT crashes per se.
Component: JavaScript Engine: JIT → Graphics
status-firefox57: --- → wontfix
status-firefox58: --- → fix-optional
Priority: -- → P3
(Reporter)

Comment 15

8 months ago
Sorry for the long unresponsive for this.
I'm back now but I did not see this bug anymore, so I can not give more details about this bug.
I am currently using version 57.0b14 (64-bit).
Flags: needinfo?(vhtnghia)

Comment 17

2 months ago
this also happens with WR enabled
You need to log in before you can comment on or make changes to this bug.