High heap-unclassified on facebook

RESOLVED DUPLICATE of bug 1379139

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1379139
5 months ago
4 months ago

People

(Reporter: Khaled Ghalmi, Unassigned, NeedInfo)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [MemShrink][platform-rel-Facebook])

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8884136 [details]
Sans titre.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170706060058

Steps to reproduce:

I'm on nightly 56.0a1 x64 Version of 6 july 2017

I left www.facebook.com opened with a youtube music video and web.whatsapp.com all this in backround


Actual results:

Excessif RAM usage and disk is satured even when closing everything

3,641.63 MB (100.0%) -- explicit
├──2,608.97 MB (71.64%) ── heap-unclassified
├────575.68 MB (15.81%) -- network
│    ├──575.58 MB (15.81%) -- cache2
│    │  ├──556.60 MB (15.28%) ── disk-storage()
│    │  └───18.98 MB (00.52%) ++ (7 tiny)
│    └────0.10 MB (00.00%) ++ (5 tiny)
├────210.17 MB (05.77%) -- js-non-window
│    ├──172.03 MB (04.72%) -- zones
│    │  ├──167.27 MB (04.59%) -- zone(0x15c384b7000)
│    │  │  ├──115.73 MB (03.18%) ++ (359 tiny)
│    │  │  └───51.53 MB (01.42%) ++ strings
│    │  └────4.76 MB (00.13%) ++ (5 tiny)
│    └───38.14 MB (01.05%) ++ (2 tiny)
├─────88.90 MB (02.44%) ++ (23 tiny)
├─────63.15 MB (01.73%) -- window-objects
│     ├──50.05 MB (01.37%) -- top(about:memory, id=45)
│     │  ├──49.07 MB (01.35%) -- active/window(about:memory)
│     │  │  ├──45.50 MB (01.25%) -- dom
│     │  │  │  ├──45.47 MB (01.25%) ── orphan-nodes
│     │  │  │  └───0.03 MB (00.00%) ++ (5 tiny)
│     │  │  └───3.57 MB (00.10%) ++ (4 tiny)
│     │  └───0.98 MB (00.03%) ++ js-zone(0x15caf41a000)
│     └──13.10 MB (00.36%) ++ (7 tiny)
├─────56.22 MB (01.54%) ++ heap-overhead
└─────38.54 MB (01.06%) -- add-ons
      ├──36.43 MB (01.00%) ++ firefox@ghostery.com/window-objects/top(moz-extension://2277f384-134d-496a-bfc4-a43673ae1d8a/_generated_background_page.html, id=27)
      └───2.11 MB (00.06%) ++ (15 tiny)


3,513.83 MB (100.0%) -- heap-committed
├──3,457.61 MB (98.40%) ── allocated
└─────56.22 MB (01.60%) ── overhead

2,267.16 MB (100.0%) -- explicit
├──1,055.21 MB (46.54%) -- window-objects
│  ├──1,024.43 MB (45.19%) -- top(https://www.facebook.com/, id=2147483653)
│  │  ├────608.46 MB (26.84%) -- active
│  │  │    ├──608.38 MB (26.83%) -- window(https://www.facebook.com/)
│  │  │    │  ├──550.42 MB (24.28%) -- dom
│  │  │    │  │  ├──548.24 MB (24.18%) ── orphan-nodes
│  │  │    │  │  └────2.18 MB (00.10%) ++ (5 tiny)
│  │  │    │  ├───38.68 MB (01.71%) -- js-compartment(https://www.facebook.com/)
│  │  │    │  │   ├──33.17 MB (01.46%) ++ classes
│  │  │    │  │   └───5.51 MB (00.24%) ++ (8 tiny)
│  │  │    │  └───19.28 MB (00.85%) ++ (3 tiny)


Expected results:

I have a 8gb laptop and never had this issue before it was max 300mb/process. Even my game never sucked this much ram before

Updated

5 months ago
Whiteboard: [MemShrink]
(Reporter)

Comment 1

5 months ago
The issue seems to be with Facebook
Can you provide your list of extensions from about:support? It's possible one of those is causing your issue.
Flags: needinfo?(mental2121)
Summary: HIGH RAM/DISK USAGE → High heap-unclassified on facebook
platform-rel: --- → ?
Whiteboard: [MemShrink] → [MemShrink][platform-rel-Facebook]
This sounds like a dupe of bug 1379139. Please reopen if you are still seeing this issue with an up to date Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379139
You need to log in before you can comment on or make changes to this bug.