Closed Bug 1379108 Opened 4 years ago Closed 4 years ago

Factor GetValidationMessage() out of HTMLInputElement

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: jessica, Assigned: jessica)

References

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
Attached patch patch, v1. (obsolete) — Splinter Review
Attachment #8884721 - Flags: review?(bugs)
Comment on attachment 8884721 [details] [diff] [review]
patch, v1.

Always {} with 'if', not if (NS_FAILED(rv)) return rv;
Attachment #8884721 - Flags: review?(bugs) → review+
(In reply to Olli Pettay [:smaug] from comment #2)
> Comment on attachment 8884721 [details] [diff] [review]
> patch, v1.
> 
> Always {} with 'if', not if (NS_FAILED(rv)) return rv;

Noted, thanks.
Attached patch patch, v2.Splinter Review
Use {} with 'if'. Carrying r+.
Attachment #8884721 - Attachment is obsolete: true
Attachment #8885081 - Flags: review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/80a55d593115
Factor GetValidationMessage() out of HTMLInputElement. r=smaug
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/80a55d593115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
(In reply to Carsten Book [:Tomcat] from comment #7)
> https://hg.mozilla.org/mozilla-central/rev/80a55d593115

Nit: I’m afraid the comments for the 2 new strings match their new entities.
Oh, right, I forgot to change the name in the comment. :(
I can do that in a followup patch, thanks.
comment only, so setting r+ directly.
Attachment #8886000 - Flags: review+
Pushed by jjong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff468ed8e5a4
(followup) Fix localization notes for FormValidationDateTimeRangeOverflow/Underflow strings. comment-only, DONTBUILD
Do we win anything by not having separate date and time error strings? (at least in Polish this makes them much worse)
(In reply to Stefan Plewako [:stef] from comment #13)
> Do we win anything by not having separate date and time error strings? (at
> least in Polish this makes them much worse)

Oh, I merged them so that I can have only one piece of code in "DateTimeInputTypeBase". I wasn't aware that they use different string in other languages, my bad, do you need me to separate them again?
https://hg.mozilla.org/mozilla-central/diff/80a55d593115/dom/locales/en-US/chrome/dom/dom.properties
https://github.com/aviarypl/mozilla-l10n-pl/commit/14291a82991ff905eb3bf0c76ba7a9fa58c95588

In Polish we had sth like "Please select a date/time that is no later/earlier than %S." that seems less generic than "value" and could be more easily understandable. Not sure how that compares in English and other locales.
You need to log in before you can comment on or make changes to this bug.