3.57% tp5n main_startup_fileio (windows7-32) regression on push d890f9fc0b5c96c3583b920f73acd0dbb1f51526 (Thu Jul 6 2017)

RESOLVED FIXED

Status

()

Core
Printing: Output
P1
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: igoldan, Assigned: fatseng)

Tracking

(Blocks: 1 bug, {perf, regression, talos-regression})

Firefox Tracking Flags

(Not tracked)

Details

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=d890f9fc0b5c96c3583b920f73acd0dbb1f51526

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  tp5n main_startup_fileio windows7-32 opt e10s     67,833,249.58 -> 70,254,471.00


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7723

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Printing: Output
Product: Firefox → Core
:fatseng Looks like the Windows printing feature brought in a Talos regression also. Most probably, we will mark bug 1378797 as WONTFIX, but this one should also be investigated. Windows platform is important for us.
Flags: needinfo?(fatseng)
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #1)
> :fatseng Looks like the Windows printing feature brought in a Talos
> regression also. Most probably, we will mark bug 1378797 as WONTFIX, but
> this one should also be investigated. Windows platform is important for us.

True. In general, code size increase(1.8MB from bug 1378797) could also introduce more latency of module loading. Not sure whether it's the cause of start-up regression.
Assignee: nobody → fatseng
Status: NEW → ASSIGNED
Priority: -- → P1
(Assignee)

Comment 3

5 months ago
The patch of  Bug 1370488 is related to printing.
It shouldn't affect the main_startup_fileio.
I did some experiments.
I ran two Talos test case. One is without the patch of Bug 1370488.[1] Another ran Talos with the patch of Bug 1370488, and I added some logs.[2]
The result:
3.9% tp5n main_startup_fileio windows7-32 opt e10s    62037326[1] -> 64496619[2]

I checked the log of [2].[3] My codes don't be run in Talos test case.
Since xul.dll file size increase.(1.8MB from bug 1378797) This regression should be related to loading xul.dll.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=165d58f48c016bdb4b867487264d52057a11dcd2&selectedJob=112931136
tp5n main_startup_fileio opt e10s: 62037326

[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=7a3b8b371aece5d0ca381d1c2897619db21bba70&selectedJob=112956177
tp5n main_startup_fileio opt e10s: 64496619

[3] https://treeherder.mozilla.org/logviewer.html#?job_id=112956177&repo=try
Flags: needinfo?(fatseng)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
(Assignee)

Updated

4 months ago
See Also: → bug 1382509
(Assignee)

Comment 4

3 months ago
This was fixed by Bug 1382509
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.