Switching between Firefox windows caused tab background color to lag behind titlebar

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: benjamin, Assigned: dao)

Tracking

(Depends on 1 bug, Blocks 1 bug, {regression})

unspecified
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [photon-visual][p1])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
After bug 1196266, switching between Firefox windows with the mouse causes a pretty serious mismatch between the titlebar and the tab background for a period of time.

Screencast attached.

This is more serious when the titlebar is showing because you can see the delay visually. When the titlebar is off (the default), the delay is still there but Firefox just feels slow rather than showing a visual mismatch.
I can't reproduce on my Windows VM, but that doesn't mean other people aren't seeing this. This is a pretty serious problem.
Whiteboard: [photon-visual] → [photon-visual][triage]
(Assignee)

Comment 2

2 years ago
(In reply to Benjamin Smedberg [:bsmedberg] from comment #0)
> This is more serious when the titlebar is showing because you can see the
> delay visually.

The solution here will be to not apply the accent color beyond the title bar when the native title bar is enabled.

> When the titlebar is off (the default), the delay is still
> there but Firefox just feels slow rather than showing a visual mismatch.

There's probably not much we can do about that.
Assignee: nobody → dao+bmo
Flags: qe-verify+
Priority: -- → P1
Whiteboard: [photon-visual][triage] → [photon-visual][p1]
(Reporter)

Comment 3

2 years ago
> There's probably not much we can do about that.

Why not? Can't we at least profile and figure out why focus events aren't coming through very quickly?
(Assignee)

Comment 4

2 years ago
(In reply to Benjamin Smedberg [:bsmedberg] from comment #3)
> > There's probably not much we can do about that.
> 
> Why not? Can't we at least profile and figure out why focus events aren't
> coming through very quickly?

That's of course always a good idea, and people have in fact profiled window activation. Bug 1334642 was filed and fixed as a result. I just suspect there aren't more low-hanging fruits left.
Status: NEW → ASSIGNED
Iteration: --- → 56.2 - Jul 10
QA Contact: brindusa.tot
The other option would be to draw the titlebar as part of the Firefox content instead of using the Windows native titlebar. Then the whole window would switch delayed, but at least it would switch at the same time.
Iteration: 56.2 - Jul 10 → 56.3 - Jul 24
I don't understand why we're not using the dark blue background for Photon here. Can you clarify that?
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 8

2 years ago
(In reply to Johann Hofmann [:johannh] from comment #7)
> I don't understand why we're not using the dark blue background for Photon
> here. Can you clarify that?

Having two different and dominant colors up there doesn't sound like a good idea to me. It's too colorful and jarring.
Flags: needinfo?(dao+bmo)

Comment 9

2 years ago
mozreview-review
Comment on attachment 8885263 [details]
Bug 1379268 - Don't apply the accent color beyond the title bar when the native title bar is enabled.

https://reviewboard.mozilla.org/r/156132/#review161546

Ok, to me it sounds like the whole UI concept is getting a bit too colorful/inconsistent if the tab bar is grey, but I don't want to stall on a subjective matter. We can always change the color later.
Attachment #8885263 - Flags: review?(jhofmann) → review+

Comment 10

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a426a96fbedb
Don't apply the accent color beyond the title bar when the native title bar is enabled. r=johannh
Duplicate of this bug: 1378855

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a426a96fbedb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
QA Contact: brindusa.tot → ovidiu.boca

Comment 13

2 years ago
Verified on Windows 10 x 64 on the latest Nightly 57.0a1 ID 20170816100153. The issue is not reproducible. I will mark this bug as verified fixed. Thank you
Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: → 1418954
(Assignee)

Updated

a year ago
Depends on: 1418954
(Assignee)

Updated

a year ago
See Also: 1418954
You need to log in before you can comment on or make changes to this bug.