bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[macOS] Show all history sidebar (using vibrancy on osx) is unreadable when using the default theme

RESOLVED FIXED

Status

()

Core
Graphics: WebRender
P3
normal
RESOLVED FIXED
a year ago
8 months ago

People

(Reporter: marcia, Assigned: mstange)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment, 2 obsolete attachments)

Created attachment 8884437 [details]
Screen Shot 2017-07-07 at 6.03.41 PM.png

Seen while running Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170706085508 CSet: 1ae7e516e5dae3c0b537251781e1adeb50783131

Webrender is enabled in this profile.

STR:
1. At some point I switched themes from Ocean Ice back to the default theme. Restarted Nightly.
2. History | Show All History - observe the attached screenshot.

In the last hour I upgraded my machine from 10.12 -> 10.13, so that is the only major change made to this machine.

Not able to yet reproduce in another nightly profile on the same machine.
I see the same thing if I set gfx.webrender.enabled to true.

Looks like it breaks -moz-mac-vibrancy

Comment 2

a year ago
Markus, I don't know where this goes on the cocoa/webrender/graphics spectrum - can you help triage / find an owner if this is something we intend to ship (haven't stayed on top of webrender, I'm afraid) ? :-)
Component: Theme → Widget: Cocoa
Flags: needinfo?(mstange)
Product: Firefox → Core
Summary: Show all history pane is unreadable after switching back to default theme on Nightly Mac → [macOS] Show all history sidebar (using vibrancy on osx) is unreadable when using the default theme
(Assignee)

Comment 3

a year ago
This falls squarely within the graphics/webrender component: WebRender needs to support OP_SOURCE on ColorLayers.

This requires https://github.com/servo/webrender/issues/1416 .
Blocks: 1311790
Component: Widget: Cocoa → Graphics: WebRender
Flags: needinfo?(mstange)

Updated

a year ago
Whiteboard: [gfx-noted]
status-firefox56: --- → unaffected
status-firefox57: affected → unaffected
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

9 months ago
Attachment #8921165 - Attachment is obsolete: true
(Assignee)

Updated

9 months ago
Attachment #8921724 - Attachment is obsolete: true
(Assignee)

Comment 6

9 months ago
With layers-free, sidebars are no longer unreadable. I'm going to use bug 1386162 for implementing vibrancy with WebRender.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
Assignee: nobody → mstange
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.