A pending update cut frame rate on from my TV tuner card to ~5 updates a second

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
P4
normal
RESOLVED WORKSFORME
3 months ago
a month ago

People

(Reporter: Yani, Unassigned)

Tracking

({perf})

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170707063454

Steps to reproduce:

Firefox download an update and user postpones applying it. 


Actual results:

I can 'feel' these updates. Thinks 'Oh Firefox must have downloaded an update something is weird'.

Today said update managed to cut frame rate on from my TV tuner card to ~5 updates a second. Even using Davinci Resolve which eats up the GPU memory can't manage that.

Opened the task manager and couldn't see anything particularly strange.

Closed all other application and the issue persisted.

Killed Firefox and the issue was gone. Restarted Firefox and there was no issue.

I've been going to comment on this for a while but I don't have a clear statement other than this update process causes various weirdness. Doesn't seem like much of a way to write a bug report. And I did think someone else would notice but that doesn't appear to be the case. 

I think there is almost definitely something buggy in the update process. Something that is noticeable only when it is postponed or in some way ignored. 

Sorry I can't be more clear. It not something I can see in an excess of memory use or CPU activity. Why it would reduce the frame rate of the TV output is new. It's been something I've noticed as a stodgy feeling in Firefox before.

Updated

3 months ago
Component: Untriaged → Application Update
Keywords: perf
Product: Firefox → Toolkit
Summary: Software update stability → A pending update cut frame rate on from my TV tuner card to ~5 updates a second
On Windows with Firefox 56 all that app update does is download the update and write a simple text file so it will be applied on update. Chances are there is something else that caused this and since there was a notification regarding the update it was thought to be the cause when something else without a notification was the cause.
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> On Windows with Firefox 56 all that app update does is download the update
> and write a simple text file so it will be applied on update.
applied on restart that is
(Reporter)

Comment 3

3 months ago
I'll postpone all updates for a few days and see if I can reproduce it. I do have long sessions with the browser open.
Out of curiosity, which notification did you see?
(Reporter)

Comment 5

3 months ago
I don't know which notification. I'd guess the drop down. Anytime I see instability in FF I check in help for an update. And every time I see a waiting update. That could just be an indication of a very long browser session. Especially if no one else is observing this which is what I'd like to know and why I posted the report.
Firefox 56 is Nightly, has an update every day, and checks for updates every 2 hours so it wouldn't take a long browser session and if you haven't restarted there is a good chance that there will be an update waiting.
Is there any additional info to go on?
Flags: needinfo?(akayani)
Priority: -- → P4
(Reporter)

Comment 8

a month ago
Whatever was causing this seems to have ceased.
Flags: needinfo?(akayani)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.