cairo-pdf-surface.c uses deprecated _BSD_SOURCE instead of _DEFAULT_SOURCE

RESOLVED DUPLICATE of bug 1379502

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1379502
11 months ago
10 months ago

People

(Reporter: goldsnakeking, Unassigned)

Tracking

56 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170709180027

Steps to reproduce:

compiled firefox


Actual results:

"_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"


Expected results:

no error reported
(Reporter)

Updated

11 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

11 months ago
Created attachment 8884650 [details] [diff] [review]
cairo-pdf-surface.c

_BSD_SOURCE replaced with _DEFAULT_SOURCE

Updated

11 months ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379502
You need to log in before you can comment on or make changes to this bug.